Support » Fixing WordPress » Categories not working after upgrade to 3.1

  • Starlet

    (@starlet)


    Hello all, I just upgraded my wordpress to 3.1 and my categories have stopped working properly.

    They are all still there and the posts are in the correct categories in my admin area, but if you go directly to a category ALL posts show eg:
    http://realitytvfan.org/category/the-amazing-race/

    You should only see posts here that begin “The Amazing Race….” but you see all posts on my blog.

    I have already tried the obvious and common suggestions such as using the default theme and disabling plugins and this does not help.

    Thanks 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator keesiemeijer

    (@keesiemeijer)

    moderator

    – Try re-saving your permalink structure or use the default structure at Settings/Permalinks in your admin panel. If WordPress cannot automatically edit the .htaccess file, it will provide manual instructions after saving.

    MikeMovies

    (@mikemovies)

    fyi my categories AND my news pages are fubared. I tried resaving my htaccess file and it did not fix it. Tried uploading an old working htaccess file still screwed.

    Help?

    @mikemovies, it’s best to start a new thread rather than hijack someone else’s as your issues may not be related. Have you tried switching to twentyten theme, and deactivating all plugins and testing? That’s the standard thing to do first off. I had some plugin become incompatible with this upgrade

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Try removing your .htaccess and letting WP generate it on it’s own. See if that works.

    Starlet

    (@starlet)

    Thanks all. I have tried all the suggested things but it has not solved the problem.

    Any other suggestions welcomed as obviously on a 4 year old site with over 5000 posts I need my categories to work 🙁

    Starlet

    (@starlet)

    The following from keesiemeijer in another thread solved the problem for me

    Also:
    Simple Tags plugin has been reported braking wordpress 3.1 categories. If you are you using it:
    uncheck “Active tags for page” and everything will be ok

    Thank you 🙂

    Simple Tags plugin issue fix reported by Starlet totally helped me.

    Thank you, Starlet!

    my category search was not working.. but changing permalinks to default as said by keesiemeijer solved the problem..

    If this doesn’t solve your category/tag link list 404’s (pulldown and top level menus) when you have a custom permalink for Blog Posts, try this “action” function. It’s worked on every site I’ve tried (including multi-sites) WITHOUT having to tinker with .htaccess, change the existing permalink structure, or disable any installed plugins.

    The problem is with 3.1’s canonical redirect. Sometimes, just disabling the redirect fixes the pblm. But, if this doesn’t solve it for you, here’s a more extensive alternative hotfix link. Just put the code in your theme’s functions.php file.

    http://wpcodesnippets.info/blog/how-to-fix-the-wp-3-1-custom-permalinks-bug.html

    Here is the solution that works.

    Disable all the plugin and install this plugin

    http://wordpress.org/extend/plugins/permalink-fix-disable-canonical-redirects-pack/

    A wonderful fix. And Thanks a million to the developer.

    My guess is this problem is also caused by ALL in one SEO

    Thanks keesiemeijer

    Try re-saving your permalink structure or use the default structure at Settings/Permalinks in your admin panel.

    Switching my permalink structure to default, and then back to what I wanted it to be totally fixed my messed up categories 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Categories not working after upgrade to 3.1’ is closed to new replies.