Support » Plugin: Gutenberg » Categories not available in Gutenberg

  • Resolved BearsongSample

    (@bearsongsample)


    Hi,

    I am trying out Gutenberg 3.6.2 on a staging WordPress 4.9.8 site which is locked down. Unfortunately I cannot share it publicly.

    The below details are identical on all browsers I test with: Chrome, Firefox, Edge (latest versions). I am open to any ideas, suggestions and advice.

    The new features all work fine except categories are not showing. The only option is to “create a new category.” That option works but only for the post when it is created. Any new posts gives only the option to “create a new category” again. (The new category is saved in the list of all categories but not accessible in Gutenberg like the pre-existing categories.)

    I have tried deactivating practically every plugin on the site, installed and reinstalled Gutenberg, deactivated and reactivated it, etc. I also tried removing the child theme and running a default built-in theme. No change.

    If my staff cannot choose the appropriate category for their posts then Gutenberg is not a viable option for us.

    The blog has been around for many years so starting over on categories isn’t viable either.

    (Tags are in the same situation but not of as great a concern).

    Thanks ahead of time.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Courtney P.K.

    (@courtneypk)

    Hi there! Sorry that you’re running into issues seeing categories and tags.

    Some security related plugins may have disabled all, or parts of, the REST API. This is used by Gutenberg to fetch all the data used to display content in the editor, so if you are missing fields, check if you have a security plugin enabled, and if it has an option for the REST API.

    If you think you’ve discovered a bug in Gutenberg, could you please log an issue on the GitHub repo?

    Thanks!

    BearsongSample

    (@bearsongsample)

    Hi, I should have mentioned it. I have no security plugins and cannot find anything else to check for REST API. I have no idea if I have discovered a bug or not. The only thing about categories not showing relates to REST API. Any suggestions on what else I can check or try most appreciated. I’ve run out now.

    Thanks.

    Courtney P.K.

    (@courtneypk)

    Hi again — No problem, thanks for following up.

    It does still sound like a REST API issue. We suggest that you use your browser’s developer tools to check for errors when the page is loading (i.e., the Network tab).

    Thanks!

    BearsongSample

    (@bearsongsample)

    ok. I will do that. And if there are no REST API issues? This illustrates why I, for one, am very leery of this entire new layout/concept and would highly prefer it be optional not required. Not to mention some of the things one can do with Gutenberg are not things I want my editors to be able to do. It’s not an encouraging start.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    And if there are no REST API issues?

    If there were no REST API issues, then it would probably be working as intended.

    This is why we test. When you load the editor, look at the javascript console and see if there are any errors there.

    It is quite likely that something on your hosting service is blocking REST requests, and since the new editor relies on that, then it is important to figure out those issues so that the team can work with the hosts on fixing those problems.

    I have had this same issue today sometimes it corrects itself after you save draft the categories will appear sometimes it’s just very delayed I have no security plugins, however, I do use cloud flare.

    other strange issues I have since installing Gutenberg I cannot just type in a youtube video URL the video Shows up in the editor just fine but not in the post I have use Embed to get it to show up in the post .

    the Widget feature all work great in editor view but not at all when you publish and go to the post

    When I insert an Image if the ALT Text you put in the box brings up scroll bar because it is longer then the view window the Image appears in the post with a part of the backend HTML address for the Image under the Image almost as if it is the caption if you go back edit the alt tat shorter so there is no scroll bar the issue is resolved .

    there is no simple way to ad alt tet and such for gallery Images

    BearsongSample

    (@bearsongsample)

    Interesting clue! I tried saving as draft and waiting an hour. Nothing changed on this end. I can only add new categories (for a one-time use).

    Still trying to find anything at all re REST API, etc. Still not finding anything. Unfortunately(?) for me, it is not a complex blog. I’ll be contacting my hosting company next.

    I don’t seem to have the image problem you describe. That actually works for me including the ability to center images. It does mess up the post with captions showing in the middle of the text like a typo gone wild. I may need to tweak the design; more work.

    YouTube embed doesn’t do anything to verify it worked although it does. I also have yet to learn how to resize the view. (I have a great plugin working for all video needs; appears to no longer function with Gutenberg active. My editors are not very good at hand-coding edits.)

    This click twice to publish button is going to cause me grief. It will be challenging to explain why it is considered an improvement.

    Today I am getting a “Sorry, you are not allowed to preview drafts.” on the preview button. Yesterday I got 404 errors. (I’ve changed nothing. It’s alive!)

    I really do not want to force my superiors into something they won’t like and having something that changes on its own overnight spooks me.

    I am seeing more and more my future of adding the plugin to go back to classic for as long as is possible.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    This click twice to publish button is going to cause me grief. It will be challenging to explain why it is considered an improvement.

    See, that’s not even a thing that exists. You click the Publish button and it publishes the post. One time. Not twice.

    So, everything you’re describing here tends to indicate that you have some kind of overall connectivity problem back to your server. The new editor runs in your web browser, and it needs a connection to your server to be able to do things like saving the post, previewing embedded items, all that stuff. This is what the REST API is used for, it is the way that it communicates with the server.

    Until you actually look in the Javascript console when you’re seeing these problems, so that you can see the error messages and post them, then you’re unlikely to actually solve the issues. Because it sounds like your host is blocking some requests or being really broken when it comes to communicating with the new editor, and without knowing what the errors actually are, then it is difficult to tell you how to fix them.

    You don’t have to save as a draft, or wait for an hour. That makes no real sense. The categories will either show up because the communication to the server is working, or they won’t because it is not. Without knowing the errors, there is no way to tell.

    BearsongSample

    (@bearsongsample)

    I create a post and click a blue “Publish” button on the top right.

    I get a message under the button that reads:

    Are you ready to publish?
    Double-check your settings, then use the button to publish your post.

    I have to click the blue “Publish” button again to publish the post.

    As I am exploring all facets of JavaScript, REST API, etc on this blog while leaving Gutenberg at default settings, replies saying “Not a thing that exists” is not helpful. While it may require a change at my end, at this time it does indeed exist.

    Thank you.

    Emanuel Fragoso

    (@emanuelfragoso)

    Indeed. I have the Sucuri security plugin, WordPress Tweaks option, REST API, Restricted Access. I need to disable this feature to get access to other Gutenberg editor options. It would be interesting for the team to analyze this fact that includes a security feature offered by Sucuri. Sorry my English!

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    I get a message under the button that reads:

    Are you ready to publish?
    Double-check your settings, then use the button to publish your post.

    Ahhh… I understand. That one is actually new to me. I hadn’t seen it until I tried the latest version.

    In any case, the rest of your post still seems to indicate connectivity problems. Categories not appearing, and embeds not showing up seem to indicate that your browser can’t get replies from the server, for whatever reason. There are many potential reasons for that to occur, so we need to narrow it down and try to solve them.

    For security reasons we want to limit the Rest API access. What I do not understand it’s why this G editor need API to to list my internal categories.
    We talk here about internal functionalities, for what we need API here?

    Hi,

    I’m having an issue with categories for posts. They disappeared the other day from the website, and I’m unable to add new categories. Do you know how this issue can be resolved? Having a similar problem with the WordPress menu (not saving properly).

    Moderator Marius L. J.

    (@clorith)

    As this is another users issue from many months ago, I’m going to close the thread.

    Please do open a new topic if you are seeking support, so as not to bother other users with notifications this long after their existing issues were resolved.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Categories not available in Gutenberg’ is closed to new replies.