WordPress.org

Support

Support » Plugins and Hacks » Enhanced Media Library » [Resolved] Categories not appearing in the media library filtering

[Resolved] Categories not appearing in the media library filtering

  • Hi Webbistro,

    I am using wp 3.9.1 and your plugin version 1.05 . Currently I am having the problem that I added several categories but only two of them are appearing in the “All Media Categories” filter box… Any ideas ?
    When I go to “Media Categories” and click on the “no. of files attached to the category” Column “Media” I get to my pictures associated with this category, so this works fine -even though it displays the count as 0 which I dont really care about and probably is related to my way of associating the images to the categories ( via mysql hack – for bulk editing ). But the categories themselves are addded through your plugin functionality and don’t get displayed… Or do they not get displayed because count is 0 ? I will try and find an answer to this last idea quickly.

    Greetings,

    Teknix

    https://wordpress.org/plugins/enhanced-media-library/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Indeed, setting the “count” value in the term_taxonomy table to something else than 0 adds the category to the filter in the media library… I’ll mark this as solved.

    Plugin Author webbistro

    @webbistro

    Hi @teknix,

    You are right, EML shows taxonomies in filter only when there are images assigned to them, that is count is not 0.

    It’s all about update_count_callback function of taxonomy. You can read this answer on Stackexchange http://wordpress.stackexchange.com/questions/50932/how-to-override-default-update-count-callback-for-category, maybe it will give you some ideas.

    Nadia

    p.s. I have read your other question as well, I think I will be able to reply meaningfully tonight or tomorrow.

    Plugin Author webbistro

    @webbistro

    Hi @teknix,

    Thank you. I have studied this more carefully and changed the code a bit. Now it works in harmony with WordPress native taxonomies (post categories) and shows all terms in the filter even in case there are no media files assigned to them. EML 1.1 work this way.

    Nadia

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Categories not appearing in the media library filtering’ is closed to new replies.
Skip to toolbar