WordPress.org

Forums

Categories and tags not working with permalinks enabled (1 post)

  1. MicheleVNG
    Member
    Posted 2 years ago #

    Hello everyone,
    I'm currently having a problem displaying categories and tags pages, and I hope you could help.

    It all began when I decided to move WordPress from the site root (i.e. http://www.michelevangelista.com) to a 3rd level domain (i.e. http://blog.michelevangelista.com) to make room for something else in the site root.

    My web host has an odd way to allow for 3rd level domains, since they require you to (using the real values):

    1. Add a CNAME record with name "blog" and value "www.michelevangelista.com"
    2. Add into the .htaccess file in the /htdocs/ folder the following lines:
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP_HOST} blog.michelevangelista.com
    RewriteCond %{REQUEST_URI} !blog/
    RewriteRule ^(.*)$ /blog/$1 [L]

    Practically, this should allow any visitor of blog.michelevangelista.com to see the contents of http://www.michelevangelista.com/blog.

    Having done this, I followed the Moving WordPress Codex Page to move my installation as safely as possible.
    I did everything listed in that page, including moving files to the /htdocs/blog folder, checking the Permalinks in the settings panel, updating the old references to media files with the Velvet Blues Update URLs plugin, updating the Settings > Media 'store uploads folder', and checking menu links.

    Now I'm using the /yyyy/mm/post-name permalink format, and my post links and pages work perfectly, while all the category or tag pages do not load and show a (webhost-themed) 404 error. You can try it yourself: the site is in Italian but I'm sure you'll figure out what to click.
    On the other hand, everything works fine if I disable permalinks and use just the plain siteurl.com/?cat=xx structure, but I don't like it!

    I strongly believe this issue is caused by something related to redirection, so I'll list below the 'sources of redirection' for my website.

    /htdocs/.htaccess : pastebin.com/2nSJkiWB
    /htdocs/blog/.htaccess : pastebin.com/Finefstt
    DNS settings : pastebin.com/W3W9iR75

    Can you help?

Topic Closed

This topic has been closed to new replies.

About this Topic