WordPress.org

Forums

[resolved] Categories (and Menus) not showing in Admin (6 posts)

  1. mdelfino
    Member
    Posted 10 months ago #

    In a site which has been running for some time, and, to my knowledge, has not had any updates or modifications other than content in the last week, The categories for all post types have dissapeared and if I go to the menus page in admin, there are no menus, although the site is displaying at least 2 different menus.

    I have checked the database and the table with the categories in it is still there and all categories are still there.

    I tried adding a new category and it shows in the list after adding, but if I navigate away from the categories page in adin and then back again, the new category no longer shows.

    The catgories page also shows the count of items in the page correctly and increases the count for eact additional category added.

    I can also doa search and it returns a reduced count but nothing in the list.

    To my knowledge, nothing has been done to this site at all in the last 7 days but overnight, this has happened.

    any ideas would be greatly appreciated.

    I have only found one other post which details my problem exactly, but no solution is documented there and the post is closed.

    This is the post just in case

    Thanks

    Marcel

  2. esmi
    Forum Moderator
    Posted 10 months ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder and wp-config.php & root .htaccess files - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  3. mdelfino
    Member
    Posted 10 months ago #

    Hi Esmi,

    Thanks for taking the time to respond.

    I have disabled all plugins and even activated a basic standard theme and nothing changes.

    I also reloaded all files except wp-content and wp-config.php after deleting the old ones and still no joy

    when i go to posts->categories in the admin dashboard, It shows that there are 43 items but the list is empty.

    Surely this can't be the first time this has happened... any suggestions as to where to look would be awesome.

    I am stumped personally

  4. mdelfino
    Member
    Posted 10 months ago #

    Interesting development:

    I cloned the site not including the uploads folder as it was too big (I moved that with FTP) to one of my servers and it seems to be ok there... the categories are showing again.

    I did an install from Installatron via cPanel and then used infiniteWP to clone the malfunctioning site onto the clean install site. I then copied the upload folder (/wp-content/uploads/) using FTP and tested... all is well.

    Now I'm going to try the process in reverse... doesnt eplain the problem, but does provide a work around... will update once I've done it in reverse

  5. mdelfino
    Member
    Posted 10 months ago #

    Turns out the problem was due to an upgrade on the MySQL server, a permission was incorrect and meant a temp file could not be written and once this was fixed it all came back.

    Go Figure... had to get the host to sort it out

  6. mdelfino
    Member
    Posted 10 months ago #

    Marking this as resolved

Reply

You must log in to post.

About this Topic