Support » Plugins and Hacks » WooCommerce » Catalog only shows 1 column

Catalog only shows 1 column

  • I think I’ve got most of the bugs worked out of my site, and now I’m trying to make it a little prettier, which means learning more about CSS

    Looking at my site: http://www.thebrasswardrobe.com/product-category/clothing/ I have my catalog items only showing in a single line. I believe this is due to each item’s width is taking up more than half of the allocated space in that area. However, I am unable to find where to make this change. Using Firebug I found that the content area for a single item:

    <li class="post-571 product type-product status-publish hentry instock" style="
        width: 200px;
    	<a href="http://www.thebrasswardrobe.com/product/brushed-twill-bib-shirt/">
    		<img width="150" height="150" src="http://www.thebrasswardrobe.com/wp-content/uploads/2013/06/538720-BRN-preview-150x150.jpg" class="attachment-shop_catalog wp-post-image" alt="538720-BRN-preview">
    	<span class="price"><span class="amount">$55</span></span>
    						<div class="gridlist-buttonwrap">
    	<a href="http://www.thebrasswardrobe.com/product/brushed-twill-bib-shirt/" rel="nofollow" data-product_id="571" data-product_sku="538720-BRN" class=" button product_type_variable">Select options</a>

    is taking up 490px x 259px. Where would I make a change to adjust that? Doing a temp change in firefox to like 200px x 250px looks like it would allow for almost 3 columns. But I can’t find where in my theme or woocommerce CSS I would make this change.


Viewing 2 replies - 1 through 2 (of 2 total)
  • It’s a theme css issue…

    In your very oddly named “sccss” file, change line 6 to:

    .products li {
        float: left;
        list-style-type: none;
        width: 33%;

    use <body<?php body_class(); ?>> after in header.php after check it’s work or not

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Catalog only shows 1 column’ is closed to new replies.
Skip to toolbar