Support » Plugin: Polylang » catagory page not found

Viewing 13 replies - 1 through 13 (of 13 total)
  • I have the same issue. Links in language-switcher and in links to categories in main menu are incorrect for second language – they contains language-slug. The situation is the same as thelostdutchmann has.

    P.S. I used this plugin for a long time and had no such problem until now.

    Also I’m experiencing this problem. In my bilingual blog both the links to categories work only if you delete the language slug “en/” in the path, otherwise a 404 error is generated.

    I just tested previous version (1.4) – it doesn’t have such problem. So, I compared changes in both versions and it seems that I found temporary solution. In file wp-content/plugins/polylang/frontend/frontend-links.php on line 47 there is a filter that aren’t presented in previous version of plugin. So, I commented these lines:

    add_filter('term_link', array(&$this, 'term_link'), 20, 3);

    It seems that it fixed the issue but, of cause, we need to wait for “real” solution from the author of this awesome plugin.

    Plugin Author Chouby

    (@chouby)

    I wanted to fix a bug on post format archives links and created this one 🙁

    Could you test the development version (1.4.1.1)?
    http://downloads.wordpress.org/plugin/polylang.zip

    Development version (1.4.1.1) seems to be fine. Thanks for quick response!

    thanks for the fast response and for the help

    Thank you for rapid fix. But consider that the language selector continue to working bad with categories.

    I have the same problem, can you tell me how to solve this please?
    Or do I have to install the development version you gabe here to solve it fast?
    now several pages are not showed and I get many complaints from clients
    I hope you can help me to fix this fast

    Thanks

    Personally, I installed (just replaced plugin files) development version. In any case, make a backup site and database before.

    Thanks Kg69design, I did that too and problems solved now

    Same problem here, dev version solved it.
    Great support for a great plugin.
    Keep it up! 🙂

    Same here – great!

    Thanks – Will

    Thanks for the quick response to this problem.
    I’m looking forward for the next update!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘catagory page not found’ is closed to new replies.