Support » Plugin: CataBlog » CataBlog Support Forum

  • ResolvedPlugin Author macguru2000


    Please post your support questions for CataBlog here. This is meant only for general support and feedback, their are other CataBlog topics & discussions if you do not have support request. Please look through them first, especially if you want to report a bug, which should not go here. Thanks

    – Zach

Viewing 15 replies - 1 through 15 (of 109 total)
  • kristel_ttm


    All right, well I do not know anymore how to get my images showing.
    Despite the message that the thumbnails have been regenerated. My thumbnails directory is empty.

    And even when I create a new item in wordpress (no import) it won’t upload the image (see my test item on the top of the page).

    Plugin Author macguru2000


    can you try hitting the reset button in the about page of CataBlog and then uploading an image using the standard “Add New” form in the plugin. If that still doesn’t work then you are gonna want to remove all CataBlog directories including the ones in wp-content/uploads. Let me know if you are successful and sorry for all this trouble.



    I have deleted my custom made wp-content/uploads/catablog directory, renamed the original one again (the one which is read-only) and have been re-inserting my images manually. Everything seems to work now. It’s too bad I could not replace the folder images but well.

    I still have an issue with the XML export though. The XML file is empty. So that worries me in case there is an update in the future where I need to export-import my data.

    Oh, and I made a copy of the file catablog.css in my child theme and made some modification but it did not overwrite it.

    Is there anyone else out there with an export problem ?
    Now I would like to backup my catalog before updating the plugin to version 0.9.0 but the created xml file is empty (0kb).

    Just upgraded to 0.9.0 and all of my items have disappeared!

    If I try and create more items, I get a message telling me it was created successfully, but doesn’t actually create the item.

    Not happy as I’ve spent DAYS adding items in and now they’re gone 🙁

    Plugin Author macguru2000



    keep in mind you could also do a mysql dump of the wp_catablog_items table. That should be sufficient for replicating your table data exactly as is. You should then make sure to do these two changes manually, change the price field type to float and change the name of the order field to ordinal. Don’t forget about the images as well and backup your catablog folder in the wp-content/uploads/ directory. A good article about file permissions can be read here, it might help you figure a way to upload files that you and php both have permission too.

    I don’t know why you are getting an empty file, the export feature works on all the setups I tried it with. Make sure to open the file and confirm it is empty in a text editor like textmate. You could also easily make the xml file generated, just reference the code below and make a catablog_item for each database row. Make sure you have a value for id, ordinal and image at least, also be aware of the CDATA tags which are necessary for the import process. Good luck hope I helped and I hope that 0.9 will work better in regards to exporting.

    <?xml version="1.0" encoding="UTF-8" ?>
    <catablog_items date="2010-10-20" time="14:48:31">
    		<title><![CDATA[water lillies]]></title>
    		<description><![CDATA[this is a standard windows image that is installed in every version. really i should be using a less generic image, but i am not.]]></description>
    		<tags><![CDATA[flowers nature default photo]]></tags>
    		<product_code><![CDATA[SKU #345665 UTA]]></product_code>

    Thank you for your help.
    I already made a mysql dump of the catablog table, indeed. But the problem is the image folder. I can back it up, but since I won’t have the writing permission on the new image folder (Apache owns it and I could not to change that), I won’t be able to upload my images again, remember ?

    That’s the reason I had to upload all my images manually last time.

    Plugin Author macguru2000


    A few options that I thought of about this one:

    – Is there anyway for you to login to your ftp as the apache user or get super user access, even just for changing file ownership and permission? Do you know what SSH is and can you connect to your web server that way?

    – When you made your own catablog folder did you make sure to set the privileges to read/write/execute for user/group/public, also known as 777? Also any folders or other content you upload inside the catablog directory should have permission level 777 as well. If that works then you can try different more secure permission levels.

    – Some kind of PHP script or CataBlog feature to “lock/unlock” the catablog directory and it’s content for temporary editing.

    Plugin Author macguru2000


    brownie, don’t delete anything or do anything rash. try an export and see if the file contains anything, if so, please post it here so I may read it. also, did you make an export before you upgraded, if so try importing it. If all else fails try the reset button in the about page. then a fresh import from a properly formatted xml file (look above)

    I didn’t take a backup unfortunately. If I export my data, I get the following in the output file.

    <br />
    <b>Parse error</b>:  syntax error, unexpected T_STRING in <b>/home/bananalo/public_html/wp-content/plugins/catablog/templates/admin-export.php</b> on line <b>1</b><br />

    Hope this gives you something to go on 🙂

    Many thanks in advance.

    Plugin Author macguru2000


    There is an informative article about file permissions and changing them here.

    Plugin Author macguru2000


    brownie, can you replace the first line of that file, catablog/templates/admin-export.php using the plugin editor.

    replace the line that looks like this:
    <?xml version="1.0" encoding="UTF-8" ?>

    with this line:
    <?php echo "<?xml version="1.0" encoding="UTF-8" ?>" ?>

    my thoughts are that your server is setup to process php tags <?php ?> without needing the php after the first question mark, this is an older and less desirable configuration in my humble opinion, but CataBlog should work in both if possible.

    Thank you.

    I know how to change the permission of a file or directory but in this case it won’t let me because ‘I am not Apache’. I do not know how to ‘log in’ as Apache, I tried everything I could (incl. in Plesk) to change the catablog folder permission. I also tried all kind of chmod and commands in terminal without any success (but I do not know that part well enough, I’m afraid).

    Don’t get me wrong, I love the plugin and everything works fine for now. But I won’t be able to update the plugin until I found a solution to backup/re-import my image folder.

    Thanks. I changed that line, but got a syntax error. I think the echo part needed single quotes instead of speech marks

    <br />
    <b>Parse error</b>:  syntax error, unexpected T_DNUMBER, expecting ',' or ';' in <b>/home/bananalo/public_html/wp-content/plugins/catablog/templates/admin-export.php</b> on line <b>1</b><br />

    I then changed it to the following:
    <?php echo '<?xml version="1.0" encoding="UTF-8" ?>' ?>

    … and then didn an export again, it’s showing no items.

    <?xml version="1.0" encoding="UTF-8" ?>
    <catablog_items date="2010-10-20" time="17:35:15">

    Is it looking like i’ll have to do a reset?

    Plugin Author macguru2000



    I’m sorry to hear that your table is empty, I think that reset would be the last option now. I’m not sure what happened, I really do hate when something like this happens. Perhaps you can put this in the bug reports forum with a detailed report. Please include information about your browser, server, WordPress, plugin versions before and after the upgrade and anything else you can think of.

    Also thanks for helping me fix the rendering bug in the xml export. I appreciate your patience with CataBlog, I really do want to get it to a stable place at this point and not add to many new features.

Viewing 15 replies - 1 through 15 (of 109 total)
  • The topic ‘CataBlog Support Forum’ is closed to new replies.