Support » Plugin: CataBlog » Catablog now working erratically

  • Resolved beelzebomb

    (@beelzebomb)


    Suddenly (& I mean suddenly) not working as expected.

    Was on WP 4.3 with no issues, did not upgrade to latest WP 4.4 until unexplained problems started to happen – upgrade didn’t fix.

    How My Site Should Work

      Each individual page should have new items appear at the top (descending)
      each new item should also go to the top of the home page.

    How My Site is Now Working

      No new items are appearing on the home page.
      One of the individual pages does not load items at the top (descending)

    Relevant Code:
    Home page:

    <?php  echo do_shortcode( '[catablog template="seantcatablog" category="everything-else,seating,shelving,storage,tables-and-desks,trolleys," limit="6" navigation="no" order="desc"]' );  ?>
        <?php /* echo do_shortcode( '[catablog]' );*/ ?>

    Example of Individual Page:

    <?php  echo do_shortcode( '[catablog template="seantcatablog" category="tables-and-desks" limit="10" order="desc"]' );  ?>
        <?php /* echo do_shortcode( '[catablog]' );*/ ?>

    Rogue Individual Page Where Items are Not Appearing at the Top:

    <?php  echo do_shortcode( '[catablog template="seantcatablog" category="everything-else" limit="10" order="desc"]' );  ?>
        <?php /* echo do_shortcode( '[catablog]' );*/ ?>

    I hope I’ve explained this clearly, but with other longstanding, seemingly unresolvable, issues – has Catablog simply had it’s day?

    https://wordpress.org/plugins/catablog/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Ok this is resolved.

    Here’s the solution if it helps others…

    Each line of code was requiring an addition:

    sort="date"

    So instead of:
    <?php echo do_shortcode( '[catablog template="seantcatablog" category="seating" limit="10" order="desc"]' ); ?>

    We now have:
    <?php echo do_shortcode( '[catablog template="seantcatablog" category="seating" limit="10" sort="date" order="desc"]' ); ?>

    This solves the issue – it is likely that the extra code snippet should have been included from the start, but as is the way of code, it had compensated and worked fine up until early December.

    Hi, I am glad you resolved your issue by adding the simple snippet code. Can I ask you for a favor and click on the front to say that it is compatible with WordPress 4.4.

    Thank you kindly also for sharing your solution above.

    Kind regards

    Plugin Author macguru2000

    (@macguru2000)

    Sounds to me like WordPress core changed how it sorts by default, thus you are now being forced to set the sort parameter to date. Thanks for posting your findings, I hope it helps other CataBlog users.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Catablog now working erratically’ is closed to new replies.