[resolved] Catablog, "Add to Gallery" doesn't work ! (9 posts)

  1. Wolf21
    Posted 2 years ago #

    Hi all !

    I need some help here :(
    I just installed Catablog, added some pictures, created a new gallery but the plugin doesn't let me Add my pictures in gallery. I should have a pop-up asking me in which gallery I want to put my pictures but it's just reloading the page and... that's all.

    I tried to reinstall the plugin but nothing changed.
    Is anybody know what I did wrong ?


  2. macguru2000
    Plugin Author

    Posted 2 years ago #

    Please try disabling other plugins and using a standard theme such as TwentyTen, TwentyEleven or TwentyTwelve to see if you are having a javascript conflict.

  3. Wolf21
    Posted 2 years ago #

    Hi, thank you for the answer.

    Actually it is the only plugin installed, and I'm using TwentyTen's theme.
    Here's the website : http://saveurs-marie.com/

  4. mbrsolution
    Posted 2 years ago #

    Hi @Wolf21, how much ram do you have allocated to WordPress?

    Also can you check to see if you followed the following instruction to load your images.


    Kind regards

  5. macguru2000
    Plugin Author

    Posted 2 years ago #

    Are you familiar with Firebug or the developer tools in webkit (chrome/safari)? If you could please pull up the javascript console in either of those tools and see if there is an error being thrown when you try to add images to a gallery. If there is an error, please post it here with all personal information sanitized. Thanks

  6. Wolf21
    Posted 2 years ago #

    Hi there ! Good News !

    I found the error, thanks to macguru advising me the chrome developer tools.
    Here's a screenshot of the source code : http://image.noelshack.com/fichiers/2013/07/1360842258-blogerror.png
    Actually it is a problem with the French translation using the single quote (while in the source, single quote and double quote are well dissociated). I switched my WP language to English and now it works fine.

    In catablog-fr_FR.po file,
    line 1570

    #: ../templates/admin-library.php:283
    msgid "Please select at least one catalog item first."
    msgstr "Veuillez tout d'abord sélectionner au moins un objet dans le catalogue."

    I tried to fix this on my website but the French language doesn't update with my change. So I left the English version for the moment.

  7. mbrsolution
    Posted 2 years ago #

    Hi @Wolf21, that is very good news. Well done ;)

    If your issue is now resolved could you please mark this ticket as resolved.

    Thank you kindly.

  8. macguru2000
    Plugin Author

    Posted 2 years ago #

    I think you found the elusive "French bug" that other people have reported. Awesome! Thanks so much for looking into that, now all I need is some free time to fix it...

  9. Wolf21
    Posted 2 years ago #

    You're welcome :)
    Good luck for the future

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic