Support » Plugin: Cart66 Lite :: WordPress Ecommerce » cart66 session not started

  • Resolved shortj


    I installed cart66 ecommerce WP plugin. I really like the plugin.
    The url for my store is I am using a gantry based premium theme, with some changes to the themes style css for further customization. Clicking the buy button (the “add to cart button” with the default text changed) I get returned “YOUR CART IS EMPTY” on the cart page. I turned off cache, opened the page in firefox, deactivated then reactivated cart66, deactivated plugins one by one, etc. and nothing worked until I activated the wordpress Twentytwelve theme and it fixed the problem. When I changed back to my original theme, the cart and checkout page looked good for the session I initiated in Twentytwelve but I get the cart empty message again when I initiate a new session (i.e. click the add to cart button) with my original theme active. I get the following cart 66 error log entry when I add to cart in my original theme:

    [LOG DATE: 01/28/2013 6:56:44 pm – Server time zone UTC]
    [Cart66SessionDb.php – line 98] Not starting session for this request: /wp-content/themes/rt_dominion_wp/images/backgrounds/style5/main-bg-bottom.jpg

    where main-bg-bottom.jpg is the background image for my site.

    My server/DB info: WP 3.5.1, PHP 5.2.17, MySQL5.0.96

    ‘Line 97-105 of cart66sessionDB.php reads:
    public static function setMaxLifetime($minutes) {
    if(is_numeric($minutes)) {
    self::$_maxLifetime = $minutes;
    else {
    self::$_maxLifetime = (is_numeric(Cart66Setting::getValue(‘session_length’)) && Cart66Setting::getValue(‘session_length’) > 0) ? Cart66Setting::getValue(‘session_length’) : 30;

    Any help would be greatly appreciated. I like the cart66 plugin and I like the look of my site and would like to keep both. Thanks.

Viewing 1 replies (of 1 total)
  • Have you tried switcing to PHP sessions in “Session Management ” in the cart66 debug’s tab? Cart66 does not work with ANY cache plugin, such as DB Cache Reloaded Fix etc..etc.

Viewing 1 replies (of 1 total)
  • The topic ‘cart66 session not started’ is closed to new replies.