Support » Plugins » Cart66-lite error

  • Hi All

    Any help appreciated. Installed Cart66-lite plugin but get the following error:

    Fatal error: Cart66::initCart() [cart66.initcart]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "Cart66Cart" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /home/lolachar/public_html/ on line 343

    Now I’ve read the very limited help for this (OK its free but…) and it says to look for anything starting with session_start.

    I’ve installed wordpress from scratch with no plugins, two themes and nothing seems to have this in the pages. Any further clues as to where this mysterious session_start reference may be?

    Or is this a different bug?

    Any help or feedback appreciated including those who have got this to work!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Technically, what is happening here is that the Cart66 object is getting pulled out of your session before the definition of what Cart66 is (the cart66 plugin) gets loaded. This is almost always caused by another plugin or the theme itself calling session_start() before the cart66 plugin is loaded. If you aren’t using any other plugins, some common places to look are your theme’s functions.php file and the theme’s header.php

    Also, we have the Cart66 Lite documentation available now as well.

    I am having this problem as well. Don’t see anything in functions.php or header.php. Pretty frustrated, really. First PHPurchase disappears with no ability to migrate products to Cart66, and then Cart66 just doesn’t WORK 🙁

    It really did look pretty amazing, PHPurchase is still a great product. I wouldn’t recommend Cart66 though.

    Hi Peeld. I’m sorry you are having trouble with Cart66. This is certainly a very vexing error to get because the cause of the error can be from so many different sources. We are working on solution for this right now which will be available to both Cart66 Lite and Cart66 Professional. The update that resolves this problem should be released in a few weeks, hopefully the end of this month (April 2011).

    Do you still get this problem if you temporarily disable your other plugins so that Cart66 is the only active plugin?

    i am having the same problem with a template i am working with. Is there a fix or code I can place somewhere so the site will come up. Currently I am getting the fatal error and the site content is not even loading. HELP!

    Hi altertheweb. As of Cart66 Lite 1.1 we have moved the Cart66 related session information into a database table, out of the PHP session space. This prevents other plugins/themes from trying to load the Cart66 shopping cart data from the session before the Cart66 plugin is loaded. As such, when updating to Cart66 1.1 from a Cart66 1.0.x release please be sure to deactivate/reactivate the plugin so the new database tables will be installed.

    similar comment also posted on Event Espresso forum —, with solution for older version of cart66 (assumed).

    problem revolved around session being declared before cart66 initialized / class autoloaded. in my case, event espresso was starting the session by hooking its init function too early (add_action with priority 1).

    went in to espresso init function <i>(\wp-content\plugins\event-espresso.3.0.19.b.13\espresso.php)</i> and changed priority of action hook (~line 65) from 1 to default, fixed the issue for me.

    here’s a reference for fixing the incomplete class error in general.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cart66-lite error’ is closed to new replies.