Support » Plugin: WooCommerce Blocks » Cart block stopped translating in Italian

  • Resolved francescolaperna

    (@francescolaperna)


    Hi,
    I’m using Woocommerce Block for my Cart and Checkout page but since a couple of days I’m facing a problem with translation.

    My website is in Italian, but now the Cart page has all the labels in English (see here).
    Until a week ago (more or less) labels were translated in Italian.

    Weird thing is that Checkout page instead is Italian and also, when I Edit Cart Page, the block shown is translated (as you can see here).

    Do you know why this is happening and how I can achieve to go back to Italian also for Cart page?

    PS: website language and dashboard language are both set to Italian.

    Thanks in advance,
    Francesco

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Albert Juhé Lluveras

    (@aljullu)

    Hi @francescolaperna, thanks for using the Cart and Checkout blocks!

    We will need some more information in order to better diagnose what’s happening here. First, could you check your version of WordPress, WooCommerce and WooCommerce Blocks? If they are not the last ones, I would suggest updating them.

    It would be interesting to know if something changed when the Cart block stopped showing translations. Did you change something in the settings? Did you update any plugin or install a new one?

    The issue might be caused by some conflict with other plugins or extensions, so I would suggest doing a conflict testing. There is a step-by-step guide on how to do that here:

    https://docs.woocommerce.com/document/woocommerce-self-service-guide/#section-4

    Hope that helps!

    Thread Starter francescolaperna

    (@francescolaperna)

    Hi @aljullu,
    thanks for your reply! I followed your tips and performed a conflict testing.

    I found out the conflict was generated with the plugin “WP-Optimize – Clean, Compress, Cache” which I’m using to speed-up the website.
    I still don’t know which setting in particular is causing this issue but I will try to investigate.

    Thanks,
    Francesco

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hi @francescolaperna

    I appreciate you getting back to us so quickly after going through that conflict testing. Having this information public on this thread may help others so thank you for letting us know!

    As you have a cause and a path forward, I will mark this thread as Resolved for now, but please do open a new one if you need any more help!

    Thanks,

    I have exactly the same problem, is there a solution to it?

    They could add compatibility again in the next update please, before if it worked with plugin wp-optimize.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.