Cart and delete problems version 2.0.5 (18 posts)

  1. rrvoigt
    Posted 3 years ago #

    Just switched over to Twenty Twelve and same issue.
    The problem i seem to have is:

    - sometimes i can't delete products.
    - often all the products come in de widget, but not in de cart page.
    - The checkout on the cart page doesn't seem to work, while on the widget page every thing works.

    I am using Kallyas theme and developer says it supports 2.0.5
    the http://themeforest.net/item/kallyas-responsive-multipurpose-wordpress-theme/discussion/4091658?page=41

    Please help.....




  2. James Koster
    Plugin Author

    Posted 3 years ago #

    This could be a number of things. Sessions, cache, memory etc. Quite hard to make a recommendation though. Have you checked the WooCommerce system status page for any issues?

  3. phildom
    Posted 3 years ago #

    I have raised this a number of times since Woocommerce 2 was introduced. The only sure way to put it right is to re-install Woocommerce version 1.6.6.
    Personally I think that that v2 changed sessions in some way.

  4. Mike Jolley
    Plugin Author

    Posted 3 years ago #

    Yes they changed but thats not really a problem.

    Are you using caching plugins?

  5. phildom
    Posted 3 years ago #

    I have raised this as a ticket but.....I installed a new WordPress site, a new Woocommerce 2.0.5 install and Woothemes Superstore. No other plugins and no server side caching. I tried 2012 theme. I tried Abundance theme by Theme Forest (Woocommerce specific). Tried Jigoshop and the problem does not exist using that plugin. Problem only surfaced after V2 was issued. Conclusion - it must be Woocommerce V2.


  6. Mike Jolley
    Plugin Author

    Posted 3 years ago #

    If it were a WC 2.0 only problem, I think we'd be seeing a few other complaints, not to mentioned woothemes.com wouldn't be working ;) It will be caching. Where is your site?

  7. phildom
    Posted 3 years ago #

    try the new test site at https://www.creightonscakes.co.uk/2014. Try adding and deleting a few products and see what happens. If you want access please respond through ticket number 34686.

    Thanks for showing an interest by the way

  8. samueljeden
    Posted 3 years ago #

    Just from browsing your website, from the way it is behaving. it is a caching problem.

    This does not happen when the server is correctly configured.

    Ive used woocommerce from early versions, continuously updating and i am now on the latest release via github.. this has not been a problem and my site is fully functional..

    see for yourself here.


    EDIT: i also suppose this could possibly be the way your server is dealing with the ajax requests with a caching issue combined? switch to twenty twelve or something without ajax features :).

  9. phildom
    Posted 3 years ago #

    Actually looking at your site, nice by the way, you only allow add to cart from a single product page. I tried the test site this way and it seems to work OK for some reason. Need to look into this, thanks.

    By the way it can't be a caching issue because there is no caching.

  10. samueljeden
    Posted 3 years ago #

    Thanks, its still not 100% the way i want it yet but its certainly getting there now.

    Are you 100% sure there is no caching happening? the way how one minute it shows something in the cart, refresh and then it does not show it in the cart <- that in its own right suggests that its a caching issue.

    For me, on your site, sometimes when i use the add to cart via AJAX it then takes me to the cart which does display the correct information but other times shows whats there from before (like a cached version (probably a cached version tbh) ).

    Also the problem is in removing the items from the cart (on your site) again possibly down to an ajax fault... it does not do anything for me when the link is pressed, no refresh or error/success message..

    but when refreshing the page a few times the items are actually deleted.

  11. phildom
    Posted 3 years ago #

    I know, only happens when you are not logged though. Site now in 2012 and it's the same sadly.

    How did you disable add to cart on products on a category page?

  12. samueljeden
    Posted 3 years ago #

    I removed the button by customising the template files...

    also, i still believe this is a caching issue -

    you changed the theme..

    i visited your site again, which did indeed change to the 2012 theme... i pressed the add to cart button and when it did the redirect (NON AJAX due to 20120) for the success messaged your site re-appeared in the superstore theme again on the cart page...

    it would only do this if it there was caching enabled... as this is nothing to do with the woocommerce side of things...

  13. phildom
    Posted 3 years ago #

    OK I understand but i don't have any caching plugins on the test site and my hosting says they don't use servers side caching....I'm still stuck.

    My main site (which was working fine until the latest update)is now displaying a broken message and I have a new 2013 site but this is also broken http://www.creightonscakes.co.uk/2013/.

    Both these use W3 Total Cache but exclude cart (basket) and checkout pages.

    Maybe I'm jinxed

  14. phildom
    Posted 3 years ago #

    I just added this bit of code to the header (as a test, it should go in the correct php file probably):

    header("Cache-Control: no-cache, must-revalidate"); // HTTP/1.1
    header("Expires: Sat, 26 Jul 1997 05:00:00 GMT"); // Date in the past

    and it appears to have sorted the issue, so was it indeed some form of server side caching? What do you think?

  15. Roy Ho
    Posted 3 years ago #

    Just want to drop a note, W3 Total Cache caused all kinds of problems on my own e-commerce site a little while back and even after I deleted the plugin, I still had same issues. After digging deep, I realized W3 Total Cache left lingering files that affected the whole site. It is not until I manually deleted these lingering files is where I got my site back up.

    I am sure it is not the fault of W3 Total Cache but just my lack of understanding on how to configure it to work with e-commerce type sites.

    But just want to state that if you want to check...

  16. phildom
    Posted 3 years ago #

    That hack may work on a test site but not on a real one.:(

  17. samueljeden
    Posted 3 years ago #

    @splashingpixels.com <- this is true.. i forgot about this effect.

    @phildom - it would be a caching problem, there is obviously something somewhere making your pages cache.

    something possibly on the top level? https://www.creightonscakes.co.uk/

    i see on this page W3 total cache is enabled still ^ and also it is using disk storage which is why it would leave files which are possibly the culprit still.

  18. phildom
    Posted 3 years ago #

    It's either some hidden caching or the cart is not refreshing....I dunno but thanks anyway, appreciate your time.

    I do use Total Cache but not on the new install site so there is no legacy data.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic