Support » Plugin: WP Mail SMTP by WPForms » Carriage return ignored in WP e-mails

  • Resolved thisisbbc

    (@thisisbbc)


    Hey there,

    We’ve updated the plugin recently and we’re having a weird issue since then. We’re not sure exactly which version we used previously unfortunately. We can probably dig this information out from our backup if necessary.

    The problem is that when we use WP Mail SMTP, the WordPress e-mails are sent with no carriage return, all written on the same line.

    We are configured to use Sendgrid and sending e-mails from WooCommerce or other 3rd-party plugin works fine and we don’t have any issues.

    However, for wordpress system notifications (i.e: New user registered), it’s like all <br> tags are ignored.

    Another thing we noticed, the system notifications are not encrypted via TLS as they should, they are not “signed-by” our usual whitelabeled domain and they are not “mailed-by” anything or anyone. I’m not sure if this is to be expected or not, but every messages sent by WooCommerce are secured, are signed-by and mailed-by our whitelabel domain. It makes me think that the system notification are not sent through Sendgrid.

    If you need mpre details to debug this issue let me know.

    Thank you!

Viewing 1 replies (of 1 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    Hi,

    This is a known issue with SendGrid/Mailgun and the mix of plain text and html emails, that <br> and new lines issue. It will be fixed in 1.3, should be later this month.

    Regarding the signed-by – that’s the issue I hear for the first time. I’ve just checked own test emails, and they are fine: http://cloud.supportally.com/pMXF.
    I will investigate the further, but no updates so far.

Viewing 1 replies (of 1 total)
  • The topic ‘Carriage return ignored in WP e-mails’ is closed to new replies.