Support » Plugin: Portfolio Slideshow » Captions not showing up

  • Hello,
    All of the boxes are checked for captions and titles in the settings, I have even tried using this shortcode-

    [portfolio_slideshow showdesc=true showcaps=true showtitles=true]

    But they are still not showing up.

    I am also unable to change the slideshow size.

    It says my version of this plug-in is current as well.

    • This topic was modified 1 year, 7 months ago by  lillyeverett.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ggwicz

    (@ggwicz)

    Hey @lillyeverett,

    What version of Portfolio Slideshow are you using?

    Also, what version of WordPress are you using?

    Thanks!
    George

    I’m having the same problem here. I’m testing a site upgrade to latest WordPress and Portfolio Slideshow, from WP 4.3 and PS 1.2. I’ve tried it in a page and in a text widget. I’ve also tried captions and descriptions.

    I looked at the html in my browser to compare with the old PS we had, and I see all the caption elements in the new version have a space for the text:

    <p class="slideshow-caption"> </p>

    Another odd thing I saw is that the caption elements are inside the slideshow-wrapper div, AFTER the portfolio-slideshow div, while the old version had the captions inside each slideshow-content element. I can’t see visually if the captions are being changed in the new version because they’re empty, but I do see the opacity changing for the slideshow-content elements. The caption elements have no style info to set the absolute position or opacity like the content elements do (exactly as shown above).

    Hi George

    Similar problem for me – newly installed WordPress version 4.9.5 on a 1and1 server with no other plugins, and default theme. slideshow doesn’t show captions, descriptions or titles, whatever boxes i tick or untick in the settings, or the show parameters in the [portfolio_slideshow show…] shortcode

    Is this an easy fix for you?

    I’m glad to see this plugin being updated again!
    But it is still broken in a number of places.
    Here’s what I did to fix the captions issue:

    At the bottom of portfolio-slideshow\src\views\slides.php

    before the last three lines at the bottom
    </div>
    <?php endforeach; ?>
    </div>

    add this – and the title, excerpt and description will appear:

    ` <?php
    $attachment = get_post( $slide[‘image’] );
    $title = $attachment->post_title;
    $exerpt = $attachment->post_excerpt;
    $content = $attachment->post_content;
    ?>
    <div class=”slideshow-meta”>
    <p class=”slideshow-title”>
    <?php echo sanitize_text_field( $title ); ?>
    </p>
    <p class=”slideshow-caption”>
    <?php echo sanitize_text_field( $exerpt ); ?>
    </p>
    <div class=”slideshow-description”>
    <?php echo sanitize_text_field( $content ); ?>
    </div>
    </div>

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Captions not showing up’ is closed to new replies.