Support » Plugin: Lightbox with PhotoSwipe » Captions not showing since 1.64 update.

  • Resolved Gcpt

    (@gcpt)


    Captions are no longer showing since the 1.64 update. I’ve tried both 1.64 and 1.65 and neither will show captions. I have rolled back to 1.63 in the short term hoping you can help me with this problem. Both Firefox and Edge give the same result.

    • This topic was modified 3 years, 8 months ago by Gcpt.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Arno Welzel

    (@awelzel)

    There may be a problem in getting the captions, if the image URLs used in the page are not identical to the URLs in the WordPress database – e.g. serving “https://…” but the pictures got stored as “http://…”. I’ll fix this.

    Plugin Author Arno Welzel

    (@awelzel)

    Release 1.66 should fix this, if the cause is mixing http and https in the URLs.

    Just be aware, that the plugin uses only the image caption and not the description or an alternative text. If you need description or alternative text as captions, let me know.

    Plugin Author Arno Welzel

    (@awelzel)

    Sorry – it seems, the fix still does not work in all cases. I’ll try to fix this.

    Plugin Author Arno Welzel

    (@awelzel)

    Eventually with 1.67 it should work :-).

    See as an example:
    https://arnowelzel.de/schalterblock-einer-miele-w986-austauschen

    Thread Starter Gcpt

    (@gcpt)

    Still not working for me with 1.66 or 1.67. Will only show with version 1.63.

    Plugin Author Arno Welzel

    (@awelzel)

    To localize the problem:

    1. Where did you enter the captions of the pictures – as caption, as description or as alternative text?

    2. Is the URL of the picture in the page/post identical to the URL property in the backend?

    Thread Starter Gcpt

    (@gcpt)

    I entered the captions as caption. The URL is the same on the page as the url in the media library. eg: https://www.gcps.org.au/wp-content/uploads/2018/10/44A_Flour_dance-.jpg If I look at the img.class it has the size included in the url. eg: https://www.gcps.org.au/wp-content/uploads/2018/10/44A_Flour_dance-745×1050.jpg

    • This reply was modified 3 years, 8 months ago by Gcpt.
    Plugin Author Arno Welzel

    (@awelzel)

    Hmm – this is strange.

    My use case at https://arnowelzel.de/schalterblock-einer-miele-w986-austauschen works exactly the same way. Pictures contain captions as “Caption” in the backend and the plugin has no problem getting the captions from the database and adding them as property to the image links.

    Technically:

    The plugin now does not parse the HTML code any longer to get the caption but it will try to get the caption from the WordPress database. For this it tries to get the internal post ID on the URL and then uses the post data to get the caption.

    This was needed, since the existing gallery plugins for WordPress do not use a well defined way to output the captions, but sometimes add it as aria-attributes, sometimes as figure descriptions and sometimes even as plain text without any link to the picture at all. Also pictures outside galleries may have a caption which is not included in the page at all.

    In your case it seems, WordPress can not find the internal post ID for the given image URL. At the moment I don’t know at all what might go wrong. At this point I’d use xdebug to check what’s going in detail on the webserver – but of course this is not possible with your website.

    Would you use a debug version of the plugin which collects additional information when passing a certain URL parameter to the page and output that to a log file, which you can send me? If this is OK for you, just contact me via e-mail. You find my address on my website: https://arnowelzel.de/en/about-me.

    Plugin Author Arno Welzel

    (@awelzel)

    Version 1.70 should fix this problem. Thanks for your help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Captions not showing since 1.64 update.’ is closed to new replies.