Support » Plugin: Simplest Gallery Plugin » captions not displaying

  • Resolved jenpen25

    (@jenpen25)


    Cleoni, why are my captions not showing on this page? Thanks.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author cleoni

    (@cleoni)

    Hello,
    The built-in fancybox has two settings: Fancybox WITH labels and without labels. Please check under Settings->Simplest gallery which one you have.

    Even if you see “WITH labels” in the default, please note that in each post/page you can override the settings, specifying that for that particular post/page you want the gallery without labels.
    The specific settings can be seen in Screen Options (top border) then activating the “Simplest Gallery” settings widget, finally scroll below until you see the settings. Choose “WITH labels” and click Update to save the settings for that post.

    I don’t think you have a CSS problem in your site because I don’t see labels text inside the page source code.

    Hope it helps.

    Hey thanks! That worked — I did have to go to Screen Options etc.

    Now I have another question. I’m aware that I’m pushing it here in terms of support for a free plug-in, so please tell me where I can make a donation.

    We’d like to place captions under the enlarged photos in the slideshow. These may be up to 25 words so they’re too long for under the thumbnails. Can we have them under the enlarged photos only?

    Plugin Author cleoni

    (@cleoni)

    Yes you can do it, it just requires a little tweak in the file lightbox.php you find inside the plugin folder.

    At line 164 change from:

    		if ($gallery_type == 'lightbox_labeled') {	// Add labels
    			$gall .= '<dd class="wp-caption-text gallery-caption">'.$thumb[5].'</dd>';
    		}
    

    to:

    		if (FALSE && $gallery_type == 'lightbox_labeled') {	// Add labels
    			$gall .= '<dd class="wp-caption-text gallery-caption">'.$thumb[5].'</dd>';
    		}
    

    and the labels are gone in the thumbnails.

    If you’re there, you can also tweak the lines 146+147 to remove that “Image #” label (see previous post).

    Don’t worry about the donation, a 5 star review will be more than enough. 🙂

    If you find it difficult, send me an email at info (at) simplestgallery (dot) com and we see how to manage it.

    • This reply was modified 5 months, 3 weeks ago by cleoni.

    cleoni, sorry, I tried that and it broke the page (critical error). Changed it back and it’s fine again — but with captions under thumbnails. Would you mind checking the code? Jen

    Plugin Author cleoni

    (@cleoni)

    You probably have inserted some extra char, or removed some other needed thing.

    Let’s make it simpler, at line 164 try to simply replace the part:

    $gallery_type == 'lightbox_labeled'

    with a simple zero so that it simply reads:

    if (0) {

    • This reply was modified 5 months, 3 weeks ago by cleoni.

    Yep, that worked. Thanks!

    Plugin Author cleoni

    (@cleoni)

    OK thanks, closing the ticket

    Me again. I want to remove the “Image #” from the caption. I opened lightbox.php and can’t find where to do it. TIA, Jen

    Plugin Author cleoni

    (@cleoni)

    You posted in the wrong thread.
    The issue has been discussed yet, here: https://wordpress.org/support/topic/remove-image-number/

    Sorry, I’ve posted in the other thread.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.