• Resolved Jim

    (@jwmc)


    In another topic asking about putting the caption below, rather than over, the image, the suggested solution was simple:

    .metaslider .caption-wrap {
      position: initial !important;
    }

    This does perfectly do it, but it has the side effect that the nav buttons are too far below the slider, and may be out of the viewers window. I could manipulate the position and bottom properties of .flex-control-nav to raise the dots, but then if there is a long caption, it can go over the dots. Is there a way to make it flow just below the caption?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Arreane

    (@yanex)

    Hi,

    Can you provide a link where the issue happened. I’d like to give you a more specific solution.

    Looking forward to hearing from you.

    Thread Starter Jim

    (@jwmc)

    Thanks for the reply. You can see the effect in the FlexSlider here: https://forestpathology.org/?page_id=1633. The nav dots are in an appropriate place for the longest caption, but seem too far away for the rest.

    A workaround I came up with is to place the nav dots above the slider instead of below; then they stay close.

    .metaslider .flex-control-nav {
      top: -15px;
    }
    

    (By the way, that page also has a demo of the Nuvi and Coin slider problems from the other topic.)

    • This reply was modified 2 months, 3 weeks ago by Jim.
    Plugin Support Arreane

    (@yanex)

    Hi,

    Sorry but the url you provided is throwing a 404 Page not found error – https://share.getcloudapp.com/6qurzPg1

    Thread Starter Jim

    (@jwmc)

    Sorry, I hadn’t published it since it was a test page. Hopefully this will work:
    https://forestpathology.org/ethnopathology/

    Plugin Support Arreane

    (@yanex)

    You can try adding the following CSS code below:

    .metaslider .caption-wrap {
    position: initial !important;
    }
    li.ms-image:not(.flex-active-slide) {
    position: absolute !important;
    }

    Thread Starter Jim

    (@jwmc)

    Wow, works perfectly! You’re a genius, thank you.

    Thread Starter Jim

    (@jwmc)

    Hmm, just noticed that this doesn’t work on mobile; caption still covers the image. Not sure why as the classes are still there.

    It works when simulating a phone with browser dev tools, but not on an actual iPhone.

    • This reply was modified 2 months, 3 weeks ago by Jim.
    Plugin Support Arreane

    (@yanex)

    Hi,

    I checked your site again and it seems that you haven’t added the code yet. It doesn’t work on both desktop and mobile.

    I can see that you’re using an auto optimize plugin, It’s possible that it’s still cached. You can try clearing your cache from your plugin and your browser’s cache to reflect the changes.

    Thread Starter Jim

    (@jwmc)

    I’m terribly sorry to waste your time. It does work on mobile now. WP-Optimize was merging and caching the css files and refused to purge the css cache. I had to disable the feature and manually delete the cached files.

    Plugin Support Arreane

    (@yanex)

    Hi,

    Glad to hear it’s working now. Let me know if you have any other issues.

    By the way, if you’re enjoying MetaSlider, please leave us a 5-star review. These reviews really help us out and let others find our plugin more easily.

    If you don’t think we deserve the 5 stars please let us know how we can improve, too.https://wordpress.org/support/plugin/ml-slider/reviews/?rate=5#new-post

    Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.