Support » Plugin: Captcha » Captcha posting Comment Error

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hi,

    We have received your request and it is now being processed. We will get back to you on this forum as soon as we can.

    Regards,
    BestWebSoft Support Team

    Hi,

    We have followed your link and found no errors. Did you manage to solve the problem by yourself? Do you still need our help?

    If you do, please complete the following in order to detect the problem and find its solution:
    1) Try activating a standard WP theme for a while (2014, 2015) and check if the problem remains.
    2) Try deactivating all of your plugins except Captcha and also check if the problem is still present. If it is not, please activate the plugins one-by-one, meanwhile checking, after which plugin activation the problem appears again.
    3) Provide your System status as well. Follow the next instruction – https://docs.google.com/document/d/1Wi2X8RdRGXk9kMszQy1xItJrpN0ncXgioH935MaBKtc/edit
    4) Let us know about the results.

    Sincerely,
    BestWebSoft Support Team

    Hello,
    I have not yet solved the problem, but I have to uninstall the plugin, no option I had.
    If you can help me, let me know.

    Hi,

    Please provide a link to the site where the problem occurs (Captcha plugin should be activated). Also, specify: do you use some caching plugins?

    Sincerely,
    BestWebSoft Support Team

    Having the same problem on one of my sites that uses cloudflare for caching.

    It only happens on comments that are instantly approved that should show instantly… (do not go into comments section of wp waiting for approval) Comments that go into your account for approval or denial get no error.

    Cheers

    I use WPSuper cache.

    Hi,

    Please try to deactivate your caching plugin and check how captcha works. The case is, when you use some caching plugins, the page with captcha is downloaded from the cache, and accordingly, new answer is never the same as the old question. That’s why this problem occurs.

    Sincerely,
    BestWebSoft Support Team

    Hi,

    Since there is no reply from you, we consider this topic as resolved. We hope you’ve found the solution. If you have any questions, please feel free to contact us via our Help Center – http://support.bestwebsoft.com/.

    Sincerely,
    BestWebSoft Support Team

    Let me try what you instruct. Now I am using w3tc cache plugin.

    Please try to deactivate your caching plugin and check how captcha works. The case is, when you use some caching plugins, the page with captcha is downloaded from the cache, and accordingly, new answer is never the same as the old question. That’s why this problem occurs.

    I’m having this same issue and that answer is not really helpful. Deactivating a caching plugin in a site with thousands of entries is not an option.

    Could you be more specific about which function of a caching plugin causes this?

    I use W3TC. I tested deactivating the Minify function, but it didn’t work. Could it be Object caching or Database caching? or your plugin will never work with W3TC?

    Taking a look at the code, I see on function cptch_display_captcha that you read key and time from a database option get_option( 'cptch_options' ). Since you add that option by using update_option(), the add_option() is called using $autoload = 'yes'.

    There is a related question here.

    On cptch_generate_key(), saving values on a new not autoloading option might be the solution. Your current code:

    
    ...
    $cptch_options['str_key']['key']  = md5( $str_key );
    $cptch_options['str_key']['time'] = time();
    update_option( 'cptch_options', $cptch_options );
    
    • This reply was modified 3 years, 11 months ago by IvanRF.
    • This reply was modified 3 years, 11 months ago by IvanRF.

    I’m not sure why this was marked “Resolved” as there is no solution posted? I’m getting the same “Error: Time limit is exhausted…” Disabling the caching plugin or Cloudflare is not a solution. What are the steps to take to get Captcha work with caching?

    I use W3TC. I tested deactivating the Minify function, but it didn’t work. Could it be Object caching or Database caching? or your plugin will never work with W3TC?

    Replying to myself, I disabled the Object Cache and the captcha seems to be working fine by now.

    You should add a note somewhere (maybe after plugin activation) for users with W3TC installed letting us know that Captcha by BestWebSoft is not compatible with Object Cache.

    • This reply was modified 3 years, 11 months ago by IvanRF.

    Hi,

    Thank you for taking your time to investigate the issue. We’ll add a notification for users with W3TC installed that Captcha by BestWebSoft is not compatible with Object Cache in the future update.

    Sincerely,
    BestWebSoft Support Team

    Thanks! after several days I can confirm that with Object Cache disabled it works fine.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Captcha posting Comment Error’ is closed to new replies.