Support » Plugin: W3 Total Cache » captcha not working when page caching is enabled

  • Hello,

    I use the latest version of WordPress and the latest version of the theme Divi (2.4.2, which I haven’t modified).

    I have W3 Total Cache enabled with all of the recommended settings and everything is working fine except for the Contact Form modules that my theme uses. For example at this URL: http://www.zabaan.com/courses/hindi/basic-hindi/ you’ll see a Contact Form on the bottom of the page.

    When Page Caching is enabled, the captcha on the contact forms also get cached and thus don’t work (it just produces the same numbers every time you refresh the page). The moment I disable Page Caching, it works without a hitch.

    I’ve contacted the support team at Elegant Themes (the makes of Divi) about this as well, but no one’s been able to figure out what the problem is (they had me check with my host about my PHP settings, but everything checked out).

    https://wordpress.org/plugins/w3-total-cache/

Viewing 3 replies - 1 through 3 (of 3 total)
  • You’re only.option would be to buy the pro version and use fragment caching.

    Or just not use the captcha.. OR use something like Google’s recaptcha

    Thanks for your response.

    Unfortunately the theme’s contact form doesn’t support Google’s recaptcha, though you’re right that I could turn off the captcha completely.

    I just read a little about Fragment Caching in the Pro version. It looks like it requires some advanced knowledge to set up properly?

    Yes it’s something that’s not easy to implement.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘captcha not working when page caching is enabled’ is closed to new replies.