Support » Plugin: Brilliant Web-to-Lead for Salesforce » Captcha not working on 2.0.3 – image not displaying the captcha to enter

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Nick Ciske


    Did it work in 2.0.2 or an earlier version?

    If the text isn’t working, I’m guessing your server lacks ‘free type’ support in GD/PHP?

    What host are you on?

    Not sure what ‘free type’ Gd/PHP is, but I’m on 1&1 hosting. PHP is supported. It used to work, but I dont recall what version I was on at the time. I’ve turned on captcha temporarily if you want to see this happening on a live page.

    Submit a Support Case

    Plugin Author Nick Ciske


    Checked the url but didn’t see the captcha at all (I assume you turned it off?).

    FreeType is the library PHP uses to render the text into the image.

    This will check if it’s enabled on your server:

    Upload that to your server and pull it up in a browser. Let me know what it says.

    Yes, I turned it off b/c people cant fill out the forms on my site with it enabled.

    I uploaded the page. It’s at
    It says FreeType Support Enabled

    Plugin Author Nick Ciske


    Hmmmm. So it’s something else then…

    Unfortunately, I can’t troubleshoot what I can’t see/debug. Do you have another site (or can you setup a separate test/dev subdomain) on that server where you could run the plugin with the captcha enabled and give me admin/ftp access to troubleshoot?

    I’ll send you an invite on LinkedIn. We can connect that way and I’ll be able to set you up as an admin.

    Hi Nick,

    we are using the v2.0.3 on this site, and we do have the same problem that the captcha doesn’t display properly.

    To be more precise, sometimes it displays the captcha but most of the time it doesn’t.

    Can you help me with this?


    Plugin Author Nick Ciske



    Maybe, but I need some more information:

    1. Where is your site hosted? What plan?
    2. Can I see a form that exhibits this behavior on your site (can be a non public URL)?
    3. Sometimes it displays? Can you tell me anything that might be different when it displays vs. not?
    4. Are you open to giving me admin and FTP access to troubleshoot on your server?

    Hi Nick

    1 – TPP-business account
    2 – I can only activate the captcha on the live site
    3- there is not much differences basically when it doesn’t display it and you pretend to send a message leaving the captcha box blank the system won’t go ahead and once it reloads, a new the captcha is now displayed
    4 – send me you email so I can forward to you


    Hi Nick
    I’m having the same issue with the Captcha with a rebuild on a dev site. The form is fine on the live site:
    but the Captcha doesn’t display on the same page on the dev site:
    as far as I can see both servers have all the same spec, the only difference is that the dev site is MU and the live isn’t – would that make a difference?

    Plugin Author Nick Ciske


    Multisite should not affect the captcha, no.

    Whatever it is, it’s a subtle difference at the server level (or a plugin interaction, or a database caching thing, etc).

    I haven’t been able to troubleshoot it in depth yet.



    I’m having a similar problem. The captcha image isn’t showing at the end of the form.

    I have the same issue. See log with error. Nick, can you help?

    [Tue Jan 28 15:38:59 2014] [error] [client] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘Required GD library is missing’ in /var/www/html/wp-content/plugins/salesforce-wordpress-to-lead/lib/captcha/captcha.php:92\nStack trace:\n#0 /var/www/html/wp-content/plugins/salesforce-wordpress-to-lead/salesforce.php(492): captcha()\n#1 /var/www/html/wp-content/plugins/salesforce-wordpress-to-lead/salesforce.php(838): salesforce_form(Array, false, NULL, 2)\n#2 [internal function]: salesforce_form_shortcode(Array, ”, ‘salesforce’)\n#3 /var/www/html/wp-includes/shortcodes.php(236): call_user_func(‘salesforce_form…’, Array, ”, ‘salesforce’)\n#4 [internal function]: do_shortcode_tag(Array)\n#5 /var/www/html/wp-includes/shortcodes.php(151): preg_replace_callback(‘/\\[(\\[?)(embed|…’, ‘do_shortcode_ta…’, ‘<p>We c…’)\n#6 [internal function]: do_shortcode(‘<p>We c…’)\n#7 /var/www/html/wp-includes/plugin.php(173): call_user_func_array(‘do_shortcode’, Array)\n#8 /var/www/html/wp-content/plugins/advanced-custom-fields/core/fields/wysiwyg.php(277): apply_filt in /var/www/html/wp-content/plugins/salesforce-wordpress-to-lead/lib/captcha/captcha.php on line 92

    Plugin Author Nick Ciske


    Here’s your issue: Required GD library is missing.

    The captcha requires the GD library to generate the image… as does WordPress (for auto image resizing).

    So… recompile PHP with GD support (or ask your host why GD isn’t enabled).

    Ignore above message. Installed the PHP GD extension to solve the error above.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Captcha not working on 2.0.3 – image not displaying the captcha to enter’ is closed to new replies.