WordPress.org

Forums

cbnet Really Simple CAPTCHA Comments
[resolved] Captcha not showing in Builder themes (7 posts)

  1. erwin.odendaal
    Member
    Posted 1 year ago #

    Hi,

    I've installed Really Simple Captha. It's working fine with Contact Form 7. But the cbnet Really Simple CAPTCHA Comments - captcha isn't showing under the respond forms. Do I have to add something to a Builder template to make it show?

    http://wordpress.org/plugins/cbnet-really-simple-captcha-comments/

  2. Chip Bennett
    Theme Review Admin
    Plugin Author

    Posted 1 year ago #

    The Plugin relies on the comment_form_after_fields action hook that is output as part of the WordPress core comment_form() function.

    As Builder is a commercial Theme, I don't have access to the code. You'll have to ask the iThemes folks if they're doing anything non-standard with the comment form functionality.

  3. erwin.odendaal
    Member
    Posted 1 year ago #

    I'll do that.
    Thanks.

  4. erwin.odendaal
    Member
    Posted 1 year ago #

    I had to add a line of code <?php do_action( 'comment_form_after_fields' ); ?> to the comments.php template. That shows the captcha after the "Send"-button of the comments form. Not very pretty, but it works.

  5. ronaldvw
    Member
    Posted 1 year ago #

    Builder currently doesn't use that action hook, but we are reviewing our comments templates as we speak.

  6. erwin.odendaal
    Member
    Posted 1 year ago #

    You told me to add this line of code didn't you?

  7. ronaldvw
    Member
    Posted 1 year ago #

    @erwin, yes, and it resolves the issue, but we want a more structural solution, by updating the comments template files included in our themes in an upcoming version.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic