Support » Plugin: Contact Form 7 » Captcha Issue

  • Resolved webdev


    Hi Guys

    When I add captcha – under “I am not a robot” there is a blank input field? Could you please advise?


Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Takayuki Miyoshi


    Try switching to the default theme (Twenty Seventeen) and deactivating all other plugins.

    Thread Starter webdev


    that’s no very helpful as I am not changing the theme or going to not use all my other plugins!!!

    @webdevmelb – this is a technique commonly used in WordPress to find what is actually causing a particular problem.

    Switch temporarily (nothing will be lost when you switch back) to a WP default theme & disable all plugins other than Contact Form 7 to see if the problem goes away.

    If it does you can switch back to your theme & re-activate each plugin one by one to see when the problem occurs.

    I’m having the same issue, it just started recently. Here is a screen shot:

    Thread Starter webdev


    I understand this however as I said we are not going to change the theme and do not have any plugins which are active that we are not using therefore even isolating a clash with a plugin is not going to assist as we are using all our active plugins.

    That’s not how debugging something works – just because you don’t wish to change the theme nor remove plugins permanently doesn’t mean it won’t help to do so temporarily to find the route cause of the problem. If there’s an incompatibility with a plugin you’ve installed and perhaps recently updated then the problem may lie with code specific to that plugin itself and not CF7 or reCAPTCHA.

    Joseph G


    I’m seeing the very same issue. When I include recaptch in a form is breaks the otherwise correct layout of the page. I’ll try disabling plugins and switching to default theme tomorrow and post results here.

    Thread Starter webdev


    other users are having the same issue so could you please resolve this from your end

    I’ve been having the same issues on one of our websites since Friday. I’ve changed the theme, disabled plugins and even reset the reCaptcha keys via Google and nothing has stopped this.

    The only thing that works is to take the Captcha off entirely, which is obviously not an ideal solution.

    • This reply was modified 3 years, 8 months ago by smiggynic.
    Joseph G


    @smiggynic I did the same thing and it still doesn’t work. I’ve disabled all plugins (minus CF7) and switched to twenty seventeen theme. I also, regenerated my Recapatcha key and re-entered it. Even after doing all this it still doesn’t work.

    Recaptcha is producing an odd box in the middle of it…

    The only thing I can now do is to remove the Captcha which isn’t so optimal. I’ve already gotten about 10 bs Pharma ads. =P

    Anyone got any ideas on how to solve this?

    Only 10 @evolutionaryit ? That’s lucky! haha.

    Also sat patiently waiting for a resolution.

    In the mean time, I’ve been using the quiz feature to stop the bots. So far it’s worked. hope this gets resolved soon. I tried redoing my Recaptcha key as well, but that didn’t help.

    Hi, I have the same problem as @webdevmelb. Why is this topic marked as resolved? It is not.

    @evolutionaryit try this plugin:, it has integration with CF7, and you don’t need to include the [recaptcha] field in the form. The only thing is you need to create new tokens for invisible recaptcha.

    • This reply was modified 3 years, 8 months ago by catalizaweb.
    Joseph G


    I think I may have found the culprit in my own environment. Looks like Wp-rocket might to be the blame in my case. Once I set Wp-rocket to NOT cache my contact page it began working just fine. Anyone else seeing this? Anyone using another caching plugin?

    I’m gonna reach out to wp-rocket support…


    yes seems to have resolved it for me as well. Also using WP-rocket here.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Captcha Issue’ is closed to new replies.