WordPress.org

Forums

Really Simple CAPTCHA
Captcha image not loading (7 posts)

  1. Amal 007
    Member
    Posted 10 months ago #

    hi,

    I have setup contactform 7 and now i have added really simple captcha,when i load the page the captcha image is not being loaded.image appers to be of broken link. When i checked the url of the captcha it appears not loading.file permission is 755 for wpcf7-captcha folder.Thanks in advance :)

    https://wordpress.org/plugins/really-simple-captcha/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 10 months ago #

    Can I check the site?

  3. Amal 007
    Member
    Posted 10 months ago #

    Is there a way i could sent the link to you privately?

  4. tmw27529
    Member
    Posted 9 months ago #

    Was this issue resolved?
    I am running into the same issue of the image not loading but when I check via ftp the image is in the folder.
    I am dealing with a server guy that does not seem to like to be bothered very much so I want to try everything I can before going back to him.
    I have already asked him to verify that the GD and FreeType libraries are installed and he said that they were.
    Any suggestions would be greatly appreciated!
    Here is a link to the page the form is on http://cyberoptics.com/cocontact/

    Thank you in advance!

  5. tmw27529
    Member
    Posted 9 months ago #

    I am not sure if this helps (b/c I don't understand it) but when I visit the actual source url of the image I get this message:

    "Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request."

  6. nosoynadie
    Member
    Posted 9 months ago #

    Hi,

    If you are using the plugin with it's default configuration, I think the problem is into "upload" folder's htaccess file. This file is activating mod_rewrite and redirecting your request to index.php file. There are two solutions:

    1. desactivate mod_rewrite into upload folder's htaccess file (maybe a bad solution)
    2. modify the pluging to do that into it's htaccess (adding this code on line 288):
      fwrite( $handle, '<IfModule mod_rewrite.c>' ."\n".'RewriteEngine Off'."\n".'</IfModule>' . "\n" );

    In my case, the option two was the solution. I hope this help you. Regards

  7. mrjcleaver
    Member
    Posted 8 months ago #

    @nosoynadie - I made the change:

    if ( $handle = @fopen( $htaccess_file, 'w' ) ) {
    			fwrite( $handle, '<IfModule mod_rewrite.c>' ."\n".'RewriteEngine Off'."\n".'</IfModule>' . "\n" );
    			fwrite( $handle, 'Order deny,allow' . "\n" );
    			fwrite( $handle, 'Deny from all' . "\n" );

    But that was still broke for me so I removed it.

    What did work for me was looking at the error log, which stated:

    [Sat Jul 05 07:32:52 2014] [alert] [client 69.165.217.125] /var/www/wordpress/wp-content/uploads/wpcf7_captcha/.htaccess: allow not allowed here

    So, checking in my case /etc/apache2/sites-enabled/wordpress.conf I see:

    <Directory /var/www/wordpress>
        Options FollowSymLinks
        AllowOverride FileInfo Options

    Now according to http://serverfault.com/questions/543789/why-is-allow-not-allowed-here-in-apache2 and http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride , to let .htaccess perform this job this line needs to include Limit, i.e. be:

    AllowOverride FileInfo Options Limit

    Then it works for me. YMMV.

Reply

You must log in to post.

About this Plugin

About this Topic