WordPress.org

Forums

Really Simple CAPTCHA
Captcha image broken (12 posts)

  1. curiousian
    Member
    Posted 1 year ago #

    Hi,

    Just pretty much finished the website and all was working great. Then, we had to move WordPress files to root and ever since that move the captcha image seems broken. Uninstalled the plugin, reinstalled, and reentered new code in Contact Form 7 plugin, but Captcha is still broken.
    I tried inserting code that was proposed in a close post thread, but it generated a 403 error for the entire website.
    Would love to keep using the Captcha!!!
    Thanks for the help!

    http://wordpress.org/plugins/really-simple-captcha/

  2. curiousian
    Member
    Posted 1 year ago #

    ...oh here is the page keauhouhideaway.com/contact-us/

  3. lmilesw
    Member
    Posted 1 year ago #

    I am having the same problem.

  4. mikeotgaar
    Member
    Posted 1 year ago #

    Its been going on for some time now - and there doesn't seem to be a solution yet.

    From what I can see, several CAPTCHA images are being generated each time e.g. 1387403326.png and 991822372.png
    but the image url in the form is *****/wp-content/uploads/wpcf7_captcha/692086990.png

    But that image is either not getting generated, or it's deleted (no idea which)

    Those are files and URL is 404 record.

    Visually - I'm seeing the image get displayed, then almost immediately roll over to a new image, and roll over again to another image or a broken image link...

    There's no clue to the reason in the WordPress or server error logs.

    The same problem exists on testing site with only CF 7 and Really Simple CAPTCHA installed and active, using default theme. Occurs with WP 3.6.1 and 3.6, but no problems with WP 3.5.1 and earlier - didn't test with 3.5.2

    I can't see anything in the plugin code to account for this behaviour - possibly it's a CF 7 issue instead.

    Don't know if this info will help the developer.....

  5. Florent Maillefaud
    Member
    Posted 1 year ago #

    It doesn't work ! I am having the same problem.

  6. Florent Maillefaud
    Member
    Posted 1 year ago #

    I suggest you add your contact page in the pages to be excluded from the cache in the advanced options, this should solve the problems.

  7. haniffali
    Member
    Posted 1 year ago #

    I had the same problem and just fixed it. The problem happened when I moved the site from newsite.example.com to example.com. I forgot about the custom work done on the wp-config.php file before I moved the site. The custom work was meant to source the "my-content" directory instead of "wp-content".

    On the wp-config.php file I changed:
    define( 'WP_CONTENT_URL', 'http://newsite.example.com/my-content');

    to:
    define( 'WP_CONTENT_URL', 'http://example.com/my-content');

    I hope this helps.

  8. jhebb
    Member
    Posted 1 year ago #

    Check the file permissions on the plugin's tmp folder. I was having the same issue and just changed the permissions and it worked.

  9. topheman
    Member
    Posted 1 year ago #

    I have the same problem.
    The images are generated correctly in the wpcf7_captcha folder.
    The link in the form is correct.
    All folders are read/writeable

    Still a broken image.
    Anyone have a tip for another contact form with captcha? It seems this has a lot of problems for a lot of people.

  10. mikeotgaar
    Member
    Posted 1 year ago #

    Try Fast Secure Contact Form with SI Captcha plugin

  11. yitwail
    Member
    Posted 1 year ago #

    This is something I just stumbled across, which may be of use to others. The captcha works fine if the page with the form isn't cached by a plugin, such as the great supercache by the plugin author. If the page *is* cached, you can get a broken image link, making the form impossible to submit. Specifically, if the captcha is part of a gravity form, this plugins 'cleanup()' method is called whenever a form is submitted, which removes all images older than an hour. It so happens I had supercache set to delete cached pages every hour. So in theory, the page shouldn't be displaying a deleted image. But perhaps it can on occasion, so I set supercache to delete pages every 30 minutes instead. I have high hopes this fixes the problem. If it turns out *not* to work, I will post a retraction.

  12. yitwail
    Member
    Posted 1 year ago #

    An update -- it didn't work, because stale files were being served, even though I set both Cache Timeout & Scheduler to 1800 seconds. I then deselected 'Cache rebuild. Serve a supercache file to anonymous users while a new file is being generated. ' because it's stale files that might have a broken image, but that STILL didn't seem to do the trick. So finally, I shortened Scheduler to 900 seconds (15 minutes). If this doesn't do the trick, I may have to consider a different cache plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Really Simple CAPTCHA
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic