Support » Plugin: Contact Form & SMTP Plugin for WordPress by PirateForms » CAPTCHA “ERROR for site owner: Invalid site key”

  • Resolved suitsjen

    (@suitsjen)


    I set up a contact form, selected Captcha and entered the site key and secret keys, but I receive this error at the bottom of the front end where the CAPTCHA appears.

    “ERROR for site owner: Invalid site key”

    I have tried this several times, but can’t figure out what I’m missing.

    I couldn’t find the answer on this forum, but I Googled it and found this:

    https://developers.google.com/recaptcha/docs/faq

    My Google Admin confirms that I’m using reCAPTCHA v2. Do I need to specify that in Pirate Forms settings? If so, where/how do I do that?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 16 through 22 (of 22 total)
  • mlayman09

    (@mlayman09)

    Oops! I meant to say no luck with V3 or V2

    @mlayman09 i agree same here it does not for even for me.

    I had this happen this morning for one site
    Can’t use the login page to fix

    Backup database first in case this makes things worse.

    What I did to fix
    Goto the database, to the table wp_options, and look for an entry called ‘aio_wp_security_configs’

    Edit that entry
    Look for something like this text and delete just that text

    “aiowps_recaptcha_site_key”;s:40:”key_text_goes_here”;s:27:”aiowps_recaptcha_secret_key”;s:40:”key_text_goes_here”;s:24:

    That should remove the recaptcha from your WP install, allowing you to log in.

    Wow I fixed the original problem by simply removing http:// from the Domain field in the Google reCaptcha configuration! Like magic!

    In the domain settings be sure to take out the http or http and www, just use the mysite.com etc. That worked for me other than

    I had the same error. I fixed it by:

    1. logging into Google reacptcha
    2. going to settings.
    3. in the Domains field, I had written in:

    https://www.idsdispatch.com

    so I added a second domain into my “domians” like this

    http://www.idsdispatch.com

    I then clicked save at the bottom of the page.

    Now it works.

    I hope that helps everyone.

    Google needs to mask the “domains” field to ensure people enter it in correctly.

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    FYI to those who need help please open a new thread: https://wordpress.org/support/plugin/pirate-forms/#new-post

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘CAPTCHA “ERROR for site owner: Invalid site key”’ is closed to new replies.