• Hi there.
    I need a little help please.
    Is there an option (which I haven’t seen?) to customize capcha coments?
    Now it’s a word and a number.
    Can it be changed that both are numbers?
    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    Now it’s a word and a number.

    The captcha is intentionally set up in this manner to make sure a human reads the captcha math sum and not a machine.

    Kind regards

    Thread Starter underro

    (@underro)

    Ok I understand, but how do I solve the situation where not all buyers know English.
    I tried Loco translate, but I couldn’t.
    I think the solution is to take the local language, and a snippet is needed.
    I tried this, with various other combinations of commands, but doesn’t work.

    function wpf_dev_recaptcha_language($url)
    {
    $my_current_lang = apply_filters( ‘wpml_current_language’, NULL );
    return esc_url_raw(add_query_arg(array(‘hl’ => $my_current_lang ), $url));
    }
    add_filter(‘wpforms_frontend_recaptcha_url’, ‘wpf_dev_recaptcha_language’, 10, 1);

    Does anyone know how I can solve this?
    Thanks.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, what language is your site set up as? Or are you running a multi-language site?

    Thank you

    Thread Starter underro

    (@underro)

    Is romanian, RO, both in settings and hreflang.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, those strings are available for translation. Something must be interfering with your language settings.

    Kind regards

    Thread Starter underro

    (@underro)

    Agree, that’s why i looking for a snippet code, which could force translation.
    I tried this too, with a few other combinations but no:

    function wpf_dev_recaptcha_language( $url ) {

    return esc_url_raw( add_query_arg( array( ‘hl’ => ‘RO ‘), $url ) );
    }
    add_filter( ‘wpforms_frontend_recaptcha_url’, ‘wpf_dev_recaptcha_language’, 10, 1);

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    I tested the math CAPTCHA in my Spanish dev site and it works for me. When I go to comment on a post, the math CAPTCHA is in Spanish.

    Are you saying in your site CAPTCHA is not appearing in Romanian?

    Kind regards

    Thread Starter underro

    (@underro)

    Hi.
    True.
    I checked twice, but I didn’t find anything wrong in the settings. Perhaps something in haste and carelessness …

    Link

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, the link proves that your po and mo language files are not fully translated. You need to investigate this further in your site. There is no need for the function code you mentioned above.

    Kind regards

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.