Support » Plugin: Capability Manager Enhanced » capability loading bug

  • Ateny

    (@sfrassanito)


    if one:
    – loads a user’s capabilities
    – sets the capabilities
    – reload the capabilities
    the role loads with the default capabilities, even if they are correctly set

    Note: when one save the new capability scheme for a given role, the page reloads with the new scheme (with red and green labels), but when one enters later in the plugin admin page and load the scheme for a given role, the default capabilities are loaded

    I have WPMU 3.4.2 via subdomains, and tried both via network activate and via single domain activation

    http://wordpress.org/extend/plugins/capability-manager-enhanced/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Kevin Behrens

    (@kevinb)

    I just tested this on WP 3.4.2 multisite with subdomains and don’t see a problem. You are scrolling down to click the Update button?

    The role defs are stored separately for each site. Is that your issue?

    Ateny

    (@sfrassanito)

    I don’t see an Update button. I see a “Save Changes”. My steps are:
    – select role in “Select Role to View / Edit”;
    – press “Load”;
    – deselect some capability;
    – press “Save Changes” on the bottom
    it save and reloads the page with the correct capabilities checked.

    This saves the capabilities, and they work correctly. Now, if I, later:
    – select same role as above in “Select Role to View / Edit”;
    – press “Load”
    it loads the default capabilities and not the ones I have just saved via “Save Changes”.

    Hope this clarify. I have v1.4.8. Thanks!

    Ateny

    (@sfrassanito)

    One doubt: can you activate it through “Network Activate”, or do you have to activate it separately for each site?

    Plugin Author Kevin Behrens

    (@kevinb)

    Activation can be network or site-specific. Role definitions are site-specific regardless.

    I’m still not able to create this error. What are the role and capability names involved? Do you have any other plugin or theme code related to role definitions which might be forcing them back to defaults?

    Plugin Author Kevin Behrens

    (@kevinb)

    What is the role of the logged user when attempting this role editing?

    Ateny

    (@sfrassanito)

    With
    – super admin, then
    – admin

    I tried to change both:
    – administrator, and
    – subscriber
    capabilities

    just to be sure.

    Plugin Author Kevin Behrens

    (@kevinb)

    What are the capability names that you tried to add or remove?

    Can you temporarily disable other plugins and switch to default theme to be sure there are no conflicts?

    Plugin Author Kevin Behrens

    (@kevinb)

    If this is/was a translated site and you previously used Capability Manager Enhanced 1.4.3 or earlier, it’s possible that the stored capability array is corrupted. If so, try Tools > Capability Manager > Reset Roles and Capabilities to WordPress defaults. This will only affect one site.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘capability loading bug’ is closed to new replies.