Support » Plugin: CAOS | Host Google Analytics Locally » CAOS works fot 1 day, then no tags found

  • Resolved baksteendegeweldige

    (@baksteendegeweldige)


    I installed the CAOS plugin on my website.
    If I use the TAG assistant (Google Chrome extension), the extension says that everything is installed correctly. If I check it the next day, it reports “no tags found”.
    The Google Analytics data is not correct.

    I configured the plugin so he doesn’t store the js scripts inside the cache folder (because I thought it had something to do with caching plugin I use).
    I now think it has something to do with the configuration of the Webhosting.
    Caos works perfectly on another site that is hosted on another Webhosting

    Do you have any idea what I should do to make it work on http://www.lazertag.be?
    Here are 2 screenshots:
    http://lazertag.be/temp/coas-options.png
    http://lazertag.be/temp/caos.png

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Hi @baksteendegeweldige (brilliant nickname, btw!),

    gtag.js isn’t loaded. Is WP Super Cache or Autoptimize stripping it from your page source?

    baksteendegeweldige

    (@baksteendegeweldige)

    It has something to do with Autoptimize or WP Super Cache (or with the Webhosting).
    If I save the settings of Caos, update GTAG, and clear the Autoptimize cache, the problem is solved, for one day at least…

    I now compared the Autoptimize settings with the other website (on the different hosting, http://www.archerytag.be, it has the same plugins, but doesn’t have the problem).

    There was one option that was not selected on the working site.
    In Autoptimize: “If your scripts break because of a JS-error, you might want to try this.” was checked, I disabled that.

    I will check if Caos is still working tomorrow.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    That must be it. The script must’ve been scraped by Autoptimize.

    I assume it’s working now!

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Btw, gtag.js is still not showing up as a request. So it’s still not working. Have you flushed all caches after changing the option?

    Hello Daan, thanks for your reply. I flushed all cached and it worked for one day. But now it doesn’t work anymore. If I flush the cache again, it works again for some time….
    (I flushed it a few minutes ago and now google tag assistant says it works again)
    I will investigate it tomorrow.
    I have the same problem on the website http://www.facetheaction.be (on the same host as http://www.lazertag.be.
    http://www.archerytag.be is on a different host, uses +- the same plugins as facetheaction.be and same theme, but doesn’t have the problem

    I did some more tests. It works again if I click on update gtag.js and flush the cache of Autoptimize (then it works for +-1 day).

    I will compare the settings of plugins on the site with problems and the site without problems tomorrow.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    But gtag.js isn’t removed? Maybe you should somehow exclude it in Autoptimize?

    No gtag.js and analytics.js aren’t removed, they are even updated (by caos). I will exclude the files in Autoptimize.

    I excluded gtag.js and analytics.js now, will see what it does tomorrow.

    Hello Daan,

    Same problem after 1 day.
    I am sure this has something to do with my hosting.
    I am going to switch hosting in December and investigate the problem (if there is a problem) then

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    HI @baksteendegeweldige,

    If it’s not a bug in CAOS, then I’m closing this issue.

    I’m very curious though, what the issue was. Could you keep me posted?

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.