Support » Fixing WordPress » Can't write .htaccess file

  • My site is running slow, so I was advised to install WP Super Cache.

    However, it won’t let me update the mod rewrite rules. I keep getting an error message saying that the .htacces file isn’t writable. I’ve tried permissions at 644 and 755 and no luck yet. I don’t know what else to do.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Those permissions are probably insufficient. Try 0666 first. If that wont work, try 0777. Either way, be sure to change the permissions back after .htaccess is updated.

    Using an FTP client such as Filezilla, copy the rules from the plugin and add those to the top of the file…were you able to enable permalinks? Some hosts don’t allow web apps like WP to have write permissions to .htaccess…

    LGRstaff

    (@lgrstaff)

    I think permalinks are enabled…I did manually copy those rules. I talked to my web host and they checked and said my permissions were fine and the file should be writeable.

    This has only occurred since I followed the wordpress codex for “Giving WordPress Its own Directory” (site was on billbayer.net/wordpress; now points to billbayer.net)

    esmi

    (@esmi)

    The site is loading very fast for me.

    LGRstaff

    (@lgrstaff)

    Now it’s loading quickly, but still says the .htaccess files are unwriteable. Which isn’t a huge deal, but it’d be nice if it was writeable. Had the same problem with WP Super Cache.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can't write .htaccess file’ is closed to new replies.