Can't view pages in 3.4 (5 posts)

  1. Raptor2m
    Posted 3 years ago #

    I upgraded to 3.4 and now I can't view any pages. Post seem to be fine. If I click on a link to a page (labeled "Resources" in my blog), it goes to my home page instead (recent posts). The URL in the browser address bar is correct, but what shows on the screen is the home page rather than the page associated with that URL.
    I tried creating a new page, but that has the same problem. I tried disabling all my plugins, but that does not solve the problem either. I tried switching to the Twenty-Eleven theme but the result was the same. Everything worked fine under 3.3.
    My site is http://reflections.cyberpastor.net I appreciate any suggestions.

  2. Arie Putranto
    Posted 3 years ago #

    Flush your permalink. It can be done by going to Setting > Permalink. Save setting without making any changes. That ought to do it ...

  3. Raptor2m
    Posted 3 years ago #

    That solved the problem. Thanks for your help!

  4. Raptor2m
    Posted 3 years ago #

    The problem has occurred again. I tried going to the Permalinks page and saving the settings, but this time it did not fix the problem. I can view posts, but the link to any of my pages gives a "not found" error.

    My permalink structure is /%category%/%postname%/ When I change it to the default I can view pages fine. But I want to keep my existing permalink structure so that my post URLs don't change.

  5. LagunaSupport1
    Posted 2 years ago #

    Thanks.. this was my issue as well. I just started with Word Press and heard how easy it was and ran into issues immediately. Thanks for the easy fix@!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic