Support » Plugin: Document Gallery » Can’t use taxonomies

  • Resolved AdRock952

    (@adrock952)


    I am having problems displaying the gallery using taxonomies.

    I created a custom taxonomy called application-forms and added it to each of my media attachments. Also each of my media attachments were uploaded to a page called Application Forms (slug: application-forms).

    On the Application Forms page i’ve added the following shortcode
    [dg fancy=true descriptions=true taxon_name=application-forms]

    I get the following message when viewing the page

    The taxon value entered, “taxon_name”, is not valid.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Dan Rossiter

    (@danrossiter)

    Hi adrock952,

    The taxonomy support in DG requires that the attachments themselves have the taxon. If I understand your description correctly, it sounds like the parent page, but not the attachments have the custom taxon.

    -Dan

    Hi Dan

    I added some code where I could add taxonomies to media file. I’ve added a taxonomy to each of my media files and because there could be loads each for a different page, i created a taxonomy. I’ve only got one so far.

    These ones i’m trying to add is for a page called Application Forms.

    Could it be because the taxonomy and the page have the same name?

    Plugin Author demur

    (@demur)

    Hi AdRock952!

    The message You’ve got indicates that there is no such taxon “taxon_name” in Your WordPress instance.
    If You haven’t explicitly defined taxonomy name it should be set to some default one. Generally category-related plugins use taxonomy category.

    Please try out:
    [dg fancy=true descriptions=true category=application-forms]

    Hope this would help You.
    Please don’t hesitate to let us know if You run into any further issues.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can’t use taxonomies’ is closed to new replies.