WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Can't Use: Maximum execution time exceeded

[Resolved] Can't Use: Maximum execution time exceeded

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author secconsult

    @mvis

    Hello Justin,

    sorry for the late response!
    This problem can arise when the inital check performed by the plugin takes more than 30 seconds.

    Please try either:

    1. Adapting the wp-config.php:
    set_time_limit(60);

    Important – If you are making changes in wp-config.php, then add this line above the “/* That’s all, stop editing! Happy blogging. */” comment.

    2. Adapting the /.htaccess file of your WordPress installation
    php_value max_execution_time 60

    3. Adapting the php.ini file
    max_execution_time = 60;

    Preferably the changes are made in the wp-config.php file.

    Please let me know if that solves the issue.

    Thanks,
    Stefan

    …If certain specific plugin actions (i.e. an initial check) require large execution times, doesn’t it seem like those should be initiated by a more explicit user interaction (i.e. “click this button to start”), and should themselves just do:

    if (!ini_get('safe_mode')) set_time_limit(0);

    …So the plugin doesn’t appear to crash?

    Plugin Author secconsult

    @mvis

    Hello Justin,

    actually that should be the case, you would have to accept the terms and conditions and click on “Continue” before the tests are run.
    As shown here http://i48.tinypic.com/1rfasj.png

    So this error message arises as soon as you click on the link in the dashboard and you are not presented with the screen as shown in the link above?

    I have just used a fresh install of the latest 3.5 WordPress (max_execution_time set to 30) and everything seems to work fine. Did you experience any other problems with your setup? Did increasing the max_execution_time solve the problem?

    I had actually installed MVIS a little while back, so it’s possible I agreed to the terms at that time. I had some problem and never successfully ran it – can’t remember why exactly, but my WP core was out of date and there were a couple other security issues I was already aware of, so I set it aside. Just tried re-installing it now, and yes, that error pops up as soon as I click the MVIS menu item in the admin panel.

    I’m now testing it locally on XAMPP (exact mirror of my production site, but I have more control over the environment and don’t mind “killing” it with tests for a bit). Same problem:

    Fatal error: Maximum execution time of 60 seconds exceeded in (mypath)\wordpress\wp-includes\class-phpass.php on line 141

    …I just lifted the execution timelimit entirely – it’s been running for 4 minutes now with httpd at 100% cpu usage an still hasn’t managed to load that admin page.

    Plugin Author secconsult

    @mvis

    That’s interesting, did the process ever complete?

    So the problem is apparently caused by a call to md5() in a do while loop.

    if (PHP_VERSION >= '5') {
                            $hash = md5($salt . $password, TRUE);
                            do {
                                    $hash = md5($hash . $password, TRUE);
                            } while (--$count);
                    }

    One quick solution should be to change one line in wp-content/plugins/mvis-security-center/inc/mvl_config.php line 4
    $password_list = array(‘123’, …) to
    $password_list = array();
    This way the loop should not be executed, but you won’t have the weak password check for your wordpress users.

    Unfortunately, I don’t know why this problem is occurring, but I will look into it some more.

    Thanks for your feedback,
    Stefan

    Never completed. I let it run for 10 minutes and then killed the httpd task.

    Changing that line does fix it.

    Plugin Author secconsult

    @mvis

    Alright, please let me know which version of XAMPP you are using and for which operating system, then I’ll try to reproduce the error.

    It happens on both my HostGator (Apache) live server and locally on XAMPP; I only tested XAMPP after discovering that it killed the production server

    Plugin Author secconsult

    @mvis

    Alright, so if I download and install the latest XAMPP (1.8.1) I should be able to reproduce the issue, right?

    Couldn’t tell you, but again, for me it happened on both XAMPP and Apache.

    Plugin Author secconsult

    @mvis

    Ok, I’ll give it another try today and will let you know the results later.

    Plugin Author secconsult

    @mvis

    Hello Justin,

    I have tried to reproduce the error you are getting on XAMPP 1.8.1 for Mac and for Linux and was not able to produce any errors after the installation of the plugin.

    This might sound exotic, but did you use the same password for your testsetup and the production system?

    Other than that unfortunately I have no further ideas than the already proposed fix.

    Please let me know.

    Plugin Author secconsult

    @mvis

    Hello Justin,

    I will put this ticket to solved now. Please let me know if there is anything else I can support you with.

    Cheers,
    Stefan

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Can't Use: Maximum execution time exceeded’ is closed to new replies.