Support » Fixing WordPress » Can’t upload site logo

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hello there.

    It is best to familiarize yourself with the limits and capabilities of your theme.

    It may be that the images you are working with are not accepted by your site due to size or dimension restrictions.

    See if your size and dimensions are the ones accepted by the parameters of your site.

    Hope this helps.

    Like i said earlier, there is no Site Logo option at all. The option to upload a logo to the site is completely missing from the customizer. I only see Site Identity, Tagline and Site icon.

    @wpbees I don’t think the problem is with the image size or type. O.P. says that the option to upload the Site Logo itself is not visible in the ‘SiteIdentity’ section.

    @cedricardo Have you tried looking under other sections in the customizer? Different Theme developers may choose to group options differently.

    @shariqkhan2012 Yes, I have looked under other sections but i see no Site Logo. I have also looked up tutorials for different themes and have found that the Site Logo option is missing from the section it should appear under.

    I am a bit confused now.
    What is the issue that you are facing? That you are not able to see the ‘Logo’ option under the ‘Site Identity’ section in the customizer? Or that you see the option, but the logo does not get displayed on the frontend?

    I just activate ‘Ample’ theme (the one which you are using) and I could see the Logo option in that section.
    However, I had to go to a different section to make the logo visible on the frontend as well.
    For that, go to Customizer->Header->Show. Then select either ‘Header logo only’ or ‘Show Both’.
    Hope this helps.

    The issue is that i do not see the ‘Logo’ option anywhere on any theme except storefront.

    That’s very strange. I am able to see it on my site with the Ample theme.
    So there is nothing wrong with the theme.

    My best guess is that there is some admin css whichis overriding the style of the ‘Logo’ control and is hiding it.

    Try disabling your plugins and see if that fixes anything.

    Or if you are a bit technical, then you could try the following:

    When you are in the ‘Site Identity’ section of the customizer, right-click the ‘Site title’ and select ‘Inspect Element’.

    You should see something like this:
    http://prntscr.com/jcsdzp

    Press Ctrl+F to search within the inspector. If your search for ‘Select Logo’ gives no matches, then there is something wrong with the theme, and I will suggest you to get a fresh copy.
    On the other hand, if the search results in non-zero matches, then the logo element is there, but is getting hidden somehow

    I have found no matches when searching for ‘select logo’. How do i get a fresh copy?

    And if the Theme is the issue, how do i have the same problem with all other themes? I have tried Zerif-Lite, Gl Multipurpose, Twenty Seventeen and a bunch of others and had the same problem with all of them.

    As I said, most probably the problem is not with the theme because the same theme is working on my system too.
    Try the plugins option too that I stated in one of the previous replies.

    I have found no matches when searching for ‘select logo’

    Can you post a screenshot of the ‘element inspector’?

    How do i get a fresh copy?

    I downloaded it from here
    Where did you get it from, the first time?

    Be double sure to make a backup of the existing copy of the theme just in case there have been some custom changes made to it.

    • This reply was modified 1 year, 6 months ago by shariqkhan2012. Reason: Corrected the formatting
    • This reply was modified 1 year, 6 months ago by shariqkhan2012. Reason: Corrected the hyperlink

    how do you take a screenshot of ‘element inspector’?

    Nevermind. I have tried the plugin option you have stated in a previous reply and it worked. I can now upload my logo.
    Thank you very much for all the help.

    You are welcome

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Can’t upload site logo’ is closed to new replies.