WordPress.org

Support

Support » How-To and Troubleshooting » Can't Upload Photos in Posts

Can't Upload Photos in Posts

  • I’m working on designing my first wordpress site at the moment and am pleased with the progress I’ve made, but when it came time to do a test post with a photo embedded inside, the photo that I uploaded via the “add media” tab in the “new post” section doesn’t work. It lets me upload the photo to the media library, and gives me a URL, but when I click “Insert into post” the picture doesn’t attach and the post remains blank.

    I’ve tried several different things, logging out, etc and nothing is working. Can someone help me please? It seems like such a simple thing, how can it go wrong?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator kmessinger

    @kmessinger

    Please work through this,
    â—¾deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin (read http://bit.ly/UhpkLl if you need help). Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder if you have one. The easiest way is to rename that folder to mu-plugins-old (read http://bit.ly/WMrMM5 for more information on mu-plugins)
    â—¾switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.

    Thanks for replying. I only had a few plugins installed and have deactivated them all, but no luck. Images are still not showing up. I’ve got the Athulapha theme installed, will this make a difference? I know it’s a very popular theme and a few of the other blogs I read use it, so I know it’s capable of of pictures etc.

    I’ll gladly switch back to the twenty eleven theme to see if I can fix it, but I’d like to back up all the work I’ve done so far. Can you tell me exactly how I would go about doing that? I’ve read the post here ( http://codex.wordpress.org/WordPress_Backups ) on backing up your wordpress blog, but I’m still a bit confused as to how exactly I do it.

    Moderator kmessinger

    @kmessinger

    I don’t think it is the theme. There is also support here, http://wordpress.org/support/theme/atahualpa

    Did you reset the plugins folder? If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin (read http://bit.ly/UhpkLl if you need help).

    Your link for your site does not work which makes it harder to check things.

    Thanks, I’ll have a look at that tomorrow – it’s very late here in England now. My site is http://www.unbecomingmymother.com

    I’m just about to try to reset the folder, but I was thinking about something else – when I click on the new post link it seems like there’s something missing. How do I edit text, add links, change font colour, etc? The only option I have is to click on the add media tab, but that’s obviously not working. I’ve included a screen shot here should there be other options when I’m trying to post a new post?

    Sorry if this is a stupid question. I’m brand new to wordpress.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can't Upload Photos in Posts’ is closed to new replies.
Skip to toolbar