Support » Fixing WordPress » Can't upload photos – fatal error – out of memory

  • Fatal error: Out of memory (allocated 70254592) (tried to allocate 19008 bytes) in /home/XXXXX/public_html/ on line 254

    That’s the error above and I am now stuck, unable to upload photos. Does anyone know where the problem is? is it a host problem or something else… what do I need to do? Please help. Thanks Fiona

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi nlpmum,

    You need to adjust your memory allocation settings in your php.ini file. Here’s a link explaining how to do so:

    Thanks so much for getting back so quickly Tim. Does this mean FTPing stuff? I’m a complete technophobe!…. I’m sure I’ll work it out. Cheers F

    Hi nlpmum,

    Well, sort of. You need to find the php.ini file via FTP and edit it. This might explain it better:

    Yikes.. Thanks for your help – I’ll have a look at the info this evening and have a go. Cheers Fiona

    I have the same problem with the same error, and have tried every fix I can find on the forums to no avail. I am trying to use my WordPress site as a CMS for many things including my high rez fine art photography.

    My 10MB image causes the failure error. I have edited the .ini, I have disabled all plugins, and nothing works. And Hostgator says its a WP problem, not them – that I am allowed more than the WP supposed limit of 64MB for an upload.

    So I resorted to good ‘ol fashioned File Manager – I went on my C-Panel and uploaded the image file into WP images/11. So now I see the jpg file there in the file manager view along with all other jpgs uploaded in November – BUT the Media Library does not “see” it. Is this approach useless or does anyone know how to get the Media Library to “see” the file and process it?



    Forum Moderator

    Aha! Thank you esmi!

    Unfortunately…when I import the file using Add to Server, I get the same/similar error message:

    Fatal error: Out of memory (allocated 68681728) (tried to allocate 14224 bytes) in /home/XXXX/public_html/wp-includes/media.php on line 254

    The image file size(s) are too large (for the current server in it’s current configuration, which you may or may not have access to the settings of)…use a photo editor to reduce the file size(s) and try again…Also upload less than your max memory allocated in one upload.

    @swansonphotos, someone else in another thread alluded to the possibility that it is the pixel size of the photo image, rather than the MB quantity size that is the real problem, although of course the two are related.

    I believe he had luck with resizing an image so that the pixel width was less than 2000.

    I just resized/resampled mine using Irfan View to a width of 1024 pixels and finally have the hassle free upload. Do you have another or better resizer to suggest?

    Hmmmm – I’ve tried different photos of different sizes and get the same problem. Rather than faffing around in the back shop, I’m waiting for a techy friend to visit and in the meantime I’m using photobox, which is a fine workaround for the moment, but then the I’m just a blogger and the quality of my photos doesn’t really matter. Cheers everyone. F

    If the quality of your photos doesn’t matter, then stop uploading 10mb big pictures. That is just asking for trouble.

    Think about it, if that 10mb image is viewed 100 times, you’ve used up 1GB of bandwidth.

    It may also be worth mentioning how long it takes to download an image of such size when you are on DSL or Dial-Upminutes?

    If you want to share a very high quality image, use an FTP client to upload to a folder and provide a download link, which includes a reference to the file size.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can't upload photos – fatal error – out of memory’ is closed to new replies.