WordPress.org

Support

Support » Plugins and Hacks » Co-Authors Plus » Can't upload or edit images or gallery without deactivating co-authors plus

Can't upload or edit images or gallery without deactivating co-authors plus

  • In the last day or two I have not been able to upload images or edit existing images or galleries without deactivating the co-authors plus plugin first.

    (I recently updated to WP-3.8.1 and CAP-3.1.1 and did not have this issue before)

    Anyone have ideas of how to solve this or where I might look for compatibility issues?

    Thanks in advance.

    https://wordpress.org/plugins/co-authors-plus/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Daniel Bachhuber

    @danielbachhuber

    Hi joegosen:

    In the last day or two I have not been able to upload images or edit existing images or galleries without deactivating the co-authors plus plugin first.

    What role is your user, and have you done any modifications to its capabilities? Also, any plugins you’ve installed recent, etc. that might’ve changed your setup?

    I have an admin role and haven’t modified it.

    All the plugins I use for my Genesis theme were in place before I installed C-AP and I haven’t had any issues with it until this week.

    Have been using the tiled gallery via Jetpack. I installed the nextgen gallery plugin and tried it out for a couple hours (and encountered the same issue of not being able to edit unless I deactivate C-AP). reverted back to the Jetpack tiled gallery.

    Any other places I should look? BTW, I really like the Co-Authors Plus and want to make this work again, so any advice would be greatly appreciated.

    (The site is under construction and is password protected at the moment, otherwise I would include a link.)

    I might add that when I go to edit a picture in the media library I get a broken link for the picture (when the plugin is activated). When I upload a photo I get an error message when the plugin is activated.

    Plugin Author Daniel Bachhuber

    @danielbachhuber

    I can’t reproduce on my install, sorry 🙁 I can help you debug further by looking at your codebase, but it would come at a fee.

    I deleted all of the users and reinstalled the plugin and it’s working again. I believe I added a line or character on my functions.php that messed it up to begin with. User error. All is good now. Thanks.

    I’m having what appears as a similar issue.

    @ joegosen Can you double check if the images you are trying to upload, despite failing through the media uploader within the post/page editor, still get uploaded to the server? In my case, they do, and I can see them in the general Media page.

    Try switching back to a default theme. When I did, everything went back to normal. So in my case it’s a collision between co-authors and my theme’s functions.

    For the record, what breaks the uploading functionality is adding this to functions.php

    // Activate Co-Authors
    if ( function_exists( 'coauthors_posts_links' ) ) {
        coauthors_posts_links();
    } else {
        the_author_posts_link();
    }

    I recreated an entire functions file, line by line, testing what broke the media uploader, and this was it.

    Cannot upload additional images to an existing gallery of photos, delete the gallery, or make any changes. The existing photos appear to be frozen on the page. Where before I simply clicked anywhere in the photo gallery, I could then add, delete, make changes. Now nothing. SO wish I hadn’t done the upgrade. Everything was fine before.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can't upload or edit images or gallery without deactivating co-authors plus’ is closed to new replies.
Skip to toolbar