Support » Localhost Installs » Can't upload or change theme.

  • WordPress 3.5.1
    Using localhost Linux CenTos 6


    I’ve been reading about solutions to this problem for about a week and have found no solution to the issue. Every time I try to install a theme or upload I get this message:

    “Unable to create directory wp-content/uploads. Is its parent directory writable by the server?”

    Solutions I’ve tried that have not worked:
    1. Changing all permissions to 777.
    2. Changing group\owner to both root and apache.
    3. Adding the uploads folder through FTP.
    4. Changed the Setting>Media option of Organize my uploads into month- and year-based folders to be unchecked.
    5. Installing manually through FTP.

    Also something I now have noticed. At one point I tried using an older version of wordpress which came with different default themes. After removing everything and doing a fresh install of the newest rec version the old themes still appear and can be activated. However, when looking into my FTP client the folders for these themes are not in wp-content.

    I cannot see any other wordpress directories on my local host through FTP so I’m not sure why it would do this.

    I really hope I can get this issue fixed. It’s to the point where I’m pulling my hair out.

Viewing 4 replies - 1 through 4 (of 4 total)
  • See what your web server (Apache?) is running as.

    It would depend how PHP is loaded (mod_php, fastcgi or suphp to run as user account, etc.).

    If it runs on your localhost, local PC, then it’s easier to just add Apache to your user group, or change Apache to run as your user account to get rid of the hassle. Just edit the


    file and find and change

    User apache
    Group apache


    User YourUserName
    Group YourUserGroup

    restart Apache by running

    service httpd restart

    Heres what I received for Apache:

    httpd 14309 root 4u IPv6 38410572 0t0 TCP *:http (LISTEN)
    httpd 14311 apache 4u IPv6 38410572 0t0 TCP *:http (LISTEN)
    httpd 14312 apache 4u IPv6 38410572 0t0 TCP *:http (LISTEN)
    httpd 14313 apache 4u IPv6 38410572 0t0 TCP *:http (LISTEN)
    httpd 14314 apache 4u IPv6 38410572 0t0 TCP *:http (LISTEN)
    httpd 14315 apache 4u IPv6 38410572 0t0 TCP *:http (LISTEN)
    httpd 14316 apache 4u IPv6 38410572 0t0 TCP *:http (LISTEN)
    httpd 14317 apache 4u IPv6 38410572 0t0 TCP *:http (LISTEN)
    httpd 14318 apache 4u IPv6 38410572 0t0 TCP *:http (LISTEN)

    I attempted changing the user\group in /etc/httpd/conf/httpd.conf to both root, but that didn’t work. I’m not very experienced in Linux unfortunately.

    I see. I’ve never had this kind of problem before on hosting or my local PC running Linux (CentOS, Ubuntu, Linux Mint, etc.), so I don’t have idea either. Usually probably like this takes a lot of time debugging. What I recommended is post your questions at


    maybe somebody that had similar issues with your case can give you the tips.

    I installed WP 3.5.1 yesterday, and had the same problem. A lot of the forums said to change the permissions for the uploads folder, but I didn’t have one.

    Based on the path in the error message, I created a folder named uploads and uploaded that into wp-content. Once permissions were changed on the uploads folder, everything worked fine.

    Hope you get the same result.


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can't upload or change theme.’ is closed to new replies.