Support » Fixing WordPress » can't upload new plugins from local computer

  • background – site was hacked – 5 WP sites (38000 files), downloaded the entire www directory from host and cleaned up the hack (the code was the same everywhere) – changed ALL passwords (cpanel, ftp, mysql, wp) and many ID’s, then I uploaded all the wordpress files.

    Sites seemed to be fine. Now an odd thing has happened.

    This morning we saw

    Warning: session_start() [function.session-start]: open(/tmp/sess_7a502df57aaf9967a539ff5227445e43, O_RDWR) failed: Read-only file system (30) in /home/userid/public_html/ on line 276

    causing me to remove it, then I tried to reinstall it and ran into problems.

    If I go to install a new plugin and select a zip file from my local maghine, I get

    ‘Missing a temporary folder.’

    or one of the other sites I get

    ‘The uploaded file could not be moved to /home/userid/public_html/’

    that folder has permission of 755. – I even tried making all the folders from wp-content down have 777 – no change. If I manually FTP the unzipped folder, I can activate it from within WP.

    The host’s support has been, how shall I say it, less than helpful.

    I deleted the site and manually uploaded all the wp files and no change

    I created a php.ini and pointed ‘upload_tmp_dir’ to a folder with ‘777’ no change.

    This seems to be a server user permission issue but I can get access to the logs to see what is happening.

    Any ideas?

  • The topic ‘can't upload new plugins from local computer’ is closed to new replies.