Support » Fixing WordPress » Can’t upload media when creating a post

  • internetg33k

    (@internetg33k)


    Hey all,

    I’ve had an issue since Gutenberg was released – when I create a new post, I can’t use the “Add Media” button to upload new pictures. While I can access my Media Library fine, if I switch to the “Upload Files” it just shows up as blank.

    After a short time, I installed the Classic Editor plugin (sorry Gutenberg coders, but I prefer the old school way…lol) , but the issue continued. My workaround was to upload pictures separately before creating a post, but now I’ve installed a new theme and when I try to change the header photo, the same issue happens (except it won’t even allow me to select a photo in my media gallery).

    I’ve searched the forums, but haven’t found a solution. Any help in pointing me to a way I can resolve this issue with uploading new photos when creating a post would be greatly appreciated.

    Thanks!

    ~ Traci

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator t-p

    (@t-p)

    While I can access my Media Library fine, if I switch to the “Upload Files” it just shows up as blank.

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install and activate “Health Check”: https://wordpress.org/plugins/health-check/
    It will add some additional feature under create a new menu position Tools > Site Health.
    On its troubleshooting tab, you can Enable Troubleshooting Mode. This will disable all plugins, switch to a standard WordPress theme (if available), allow you to turn your plugins on and off and switch between themes, without affecting normal visitors to your site. This allows you to test for various compatibility issues.
    There’s a more detailed description about how to use the Health Check plugin and its Troubleshooting Mode at https://make.wordpress.org/support/handbook/appendix/troubleshooting-using-the-health-check/

    Thread Starter internetg33k

    (@internetg33k)

    Thanks, @t-p! I might not have a chance to do that until Wednesday (Tuesdays are my most popular blog visitor days, so I don’t want to break anything today…lol), but I will shout out as soon as I know if it worked. Much appreciate the info!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can’t upload media when creating a post’ is closed to new replies.