Can't upload media to posts: "Is its parent directory writable by the server?" (5 posts)

  1. Lala Diva
    Posted 3 years ago #

    Hi there,

    I'm trying to upload a picture to my blog, and have so far had no problems at all. Suddenly, I'm getting this error:

    Unable to create directory (address of my server and blog follows) Is its parent directory writable by the server?

    I haven't done anything to permissions here or anywhere else, and I've looked at the path that is being used to upload media, and it is the standard wp-content/upload path.

    Can anyone help?



  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Did you try searching the forums before posting? Only this has been answered hundred (if not thousands) of times.

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

  3. Lala Diva
    Posted 3 years ago #

    Hi Esmi,

    Thanks for the reply, but I've already tried all of that and non of it works. Furthermore, I think it might be helpful for people to understand why this happens. I uploaded a picture only a day ago with no problems at all - and suddenly this happens... I've made no changes to the blog, added no more plugins... basically nothing has changed...

    Any further ideas?

    Thanks J

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    It happens because Word\press does not have the correct permissions to create folders and/or add images to the wp-content folder on your site. If the situation has changed without any apparent reason in the past few days, perhaps your hosts have changed something on your server?

  5. Lala Diva
    Posted 3 years ago #

    Hi Esmi,

    Actually, in this case, it was the fault of my hosting providers. They had migrated my website to a different server, and I had to change the server number in the path to my uploads folder via settings - media in the dashboard. It had nothing to do with permissions.

    I have told my hosts that they should have advised me as such, but it was a small oversight and they were knew exactly what to do.

    Problem solved!

    Thanks for your help though - :-)

Topic Closed

This topic has been closed to new replies.

About this Topic