Support » Fixing WordPress » Cant upload media

  • Resolved rayblo

    (@rayblo)


    Having media problems after upgrade to 3.3.

    Now i’m not able to upload any media:

    Uploaden van “2517_diddlaufblumen.png” is niet gelukt als gevolg van een fout
    Cant be moved to /srv/www/vhosts/*********.org/httpdocs/uploads.
    Rights of the map have been set to 755 also changed it to 777 nothing will help, but even weirder it worked before the upgrade

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi

    (@esmi)

    Forum Moderator

    Well worked all through nothing worked!

    esmi

    (@esmi)

    Forum Moderator

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

    Done all these steps none works 😛

    Try disabling your plugins and activating one by one. Its time consuming, but it worked for me. I had the same problem. In my case it was a plugin called WP Firewall 2 that was causing the problem. So I had to leave it disabled. Image uploader now works on my site.

    Also after doing this ie the plugin exercise above, dont forget to clear your server cache (by clicking on the clear cache button on the plugin update page). You may also need to clear your web browser cache as well.

    What ver of WP did you update from ?

    Does your server have the latest PHP protocol etc installed.. probably need to ask your server people this one? And then compare against WP 3.3 minimum req’s etc.

    I had no end of problems with updating and uploading until my server guy updated everything needed to latest versions.

    Also
    “/httpdocs/uploads.” why not put your uploads folder in the wp-content folder – this should look something like …./public_html/wp-content/uploads to which the permissions can have a lesser restriction… maybe

    Most of my problems with uploading things in WP in the past have been due to permissions and owner groups. These can be seen/noted using something like FileZilla and when i have the odd issue i go straight there to check and more often than not its to do with the DIR perms and owner. A quick email to my server guy fixes the owner group if i cant change the dir perms. for any reason myself etc

    Hope any of this helps!
    <W>

    Tried this all none worked but pff luckily i host myself and oops i forgot to take off php safe mode! And it works now.

    Thx all

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Cant upload media’ is closed to new replies.