Can't upload images larger than 128KB (HTTP error) (9 posts)

  1. gnomad
    Posted 4 years ago #

    Trying to add images to my library for the first time and if images are over 128KB I get an "HTTP error" and WP hangs on crunching with flash uploader. When using browser uploader it gets the following error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Using WP 3.2.1. This was a fresh install, no upgrade. Never install WP on this host before

    Changed theme to twenty eleven. Re-installed WP. Deleted every single plugin. Re-installed WP again.

    Changed .htaccess to this:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    # END WordPress

    Nothing has worked so far. Any image below 128KB works fine, every image above no good, amount of pixels in image doesn't affect this at all.

    Anyone have any other ideas?


  2. esmi
    Forum Moderator
    Posted 4 years ago #

    This does sound like a mod_security or server config issue. Have you asked your hosts about it?

  3. gnomad
    Posted 4 years ago #

    talking to the host, they say it might be an issue with the php.ini file.

  4. jkrouse
    Posted 4 years ago #

    having the same problem -- let me know if they have a fix.

  5. gnomad
    Posted 4 years ago #

    tried to add php.ini file in /wp-admin with lines (following someone elses advice)

    memory_limit = 100M
    upload_max_filesize = 192M
    post_max_size = 100M
    file_uploads = On

    then changed name to php5.ini, to no avail.

  6. MickeyRoush
    Posted 4 years ago #

    Can you check and see if the file that gave the error is in your uploads directory? I've had this problem before, and it would actually upload the file even after giving the error.

  7. jkrouse
    Posted 4 years ago #

    This started happening to me after the blog was up and running for two years. But it's the exact same problem -- it won't upload a file beyond a certain size and all of the .htaccess advice out there doesn't seem to work.

  8. gnomad
    Posted 4 years ago #

    Yep I have another site that used to be fine now just last week or so doesn't want to upload in WP. Checked uploads folder and definitely hasn't uploaded any of the files over 128KB.

    Using secureserver.net, with a linux server, anyone else having problems with these guys?

  9. mpilon
    Posted 4 years ago #

    If in your apache error logs you see some like...

    mod_fcgid: HTTP request length 131768 (so far) exceeds MaxRequestLen (131072)

    then you have a slightly deeper but highly fixable problem. This error means that your host is running apache as fastcgi and has the MaxRequestLen set too low. For those user on Plesk (MediaTemple uses plesk) here is a fix or at least to get a sys savvy person on the right track.


    Basically you need to mod the fcgid.conf file to allow a longer request length. On some linux distributions this is file is located at /etc/apache2/conf.d/fcgid.conf. On others it might be located at /etc/httpd/conf.d/fcgid.conf . It could also be located in another place. Whereever it is, you need to add this:

    FcgidMaxRequestLen 1073741824

Topic Closed

This topic has been closed to new replies.

About this Topic