Support » Fixing WordPress » Can’t upload images (in media library)

  • Dear people,

    Yesterday I moved wordpress from one domain to another.
    – Transferred wordpress files to new destination
    – Imported sql
    – Made sure wp-config had correct passwords and paths
    – Checked permalinks, upload path in WordPress

    The site is online and running, however, there are 2 issues.

    – No image is shown in the media libraries (while clearly there are tons of it). I can see them via FTP but in WordPress media library. This might be due the fact that I have transferred uploads map from one domain to another via FTP but I was wondering how I could solve this issue, since it would be nice we could re use images that are already uploaded.

    – The other harsh problem is that I can’t upload images into WordPress Media Library.
    When I upload it I get an error like:
    “Error when uploading. Try again later”
    However when I view the upload map using FTP, I can see that the image has actually been uploaded.
    How can I solve this issue ?

    I have tried the standard things.
    Changing permissions (777, currently set 775) and checking out the paths and stuff (its now on wp-content/uploads).
    Tried checking in preview mode to async-upload.php.

    I still havent found out what is causing this issue.
    Any help is appreciated.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator t-p

    (@t-p)

    Since Domain is changed, you need to change it everywhere in the database. If you can install plugins, install Better Search And Replace.

    Hello C2S,

    Sorry for the problem with your transferred WordPress site not being able to upload files. We have seen different problems with the upload issue. If your host uses cPanel, you can try the steps below. However, if you’re not using the cPanel for your server interface, then you simply need to be able to get to your WordPress database and then make the changes listed below.

    1) Log into cPanel
    2) Opening phpMyAdmin in the “Databases” section of cPanel.
    3) In the left navigation, expand the drop down menu and choose the WordPress database for your site.
    4) Look for the “wp_options” table in your database.
    5) Within the “wp_options” table, click the edit button to change the “option _value” field for “upload_path” to:
    /home/insert-your-cpanel-username-here/public_html/wp-content/uploads

    Note that the path may vary, but make sure to put in the correct value for your WordPress installation per the location of your WordPress installation.

    If this path is correct, try contacting your hosting support people and ask to make sure that all permissions and ownership settings for your files are set correctly.

    Regards,
    Arnel C.

    @tara, I have used DBeaver to edit the SQL files. It has a great search and replace tool. Since Ive done this before, I know what to edit.
    So the tables in SQL are probably correct.

    @arncus, in wp_options the option value for upload_path is “wp-content/uploads” (same as /home/mydomain/domains/mydomain.nl/public_html/wp-content/uploads)

    Any more suggestions ?

    • This reply was modified 3 years, 2 months ago by C2S.

    Same problem with me.
    You resolved this problems ?

    Thanks

    I have solved this issue but unfortunately I can’t remember how. If you use installatron , try moving your wordpress site to another domain and move it back.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can’t upload images (in media library)’ is closed to new replies.