Support » Fixing WordPress » Can't Upload Images after updating to 3.3

  • Resolved HLMInterior


    Has anyone updated to the new WordPress 3.3? I have an since do that I can’t upload new images. I select the media/insert button and then when I click the Select Files button nothing happens. Any having a the same problem? Does anyone have a solution?

Viewing 15 replies - 1 through 15 (of 28 total)
  • Yes, this happened to me as well. It could be an incompatible plugin or theme, so they usually tell you to turn off all your plugins and check and then enable them one by one to see which breaks it, and if that doesn’t work then switch to the default theme and check again. That will tell you where the problem is.

    In my case, it was my theme, which I had customized to load a newer version of jquery which was no longer newer and didn’t support whatever they are doing with the media uploader.


    I’m having the same problem.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Make sure you’ve read the entire Master List post and the New Features in 3.3 Post.

    Go to your own install’s about page – – to see what’s new.

    And then make sure you’ve tried…

    – flushing any caching plugins you might be running, as well as server and/or browser caches.

    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    – switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.

    – manually upgrading. When all else fails, download a fresh copy of the file of 3.3 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

    After deactivating all the plugins I was able to upload images.

    The plugin that caused to problem was WP Time Machine.

    WP Time Machine was also causing this error for me… deactivated it and everything is on and cracking again.

    May be you need to re-install all plug-ins after upgrading for 3.3 version

    Deactivated and reactived all the plugins but hasn’t helped wouldn’t work with all plugins inactive either.

    The media uploader looks like its uploading gets to 100% but then there is no image and the image hasn’t been uploaded to the server either. I tried using the old upload method as well and that also doesn’t work.

    Could someone please offer any suggestions with regards to this my client cant upload images any longer to his site.


    Deactivated and reactived all the plugins but hasn’t helped

    I have the same problem too
    and this hasn’t help

    Got the same problem with a fresh install of WP 3.3.

    I’ve checked the folders permission thrice (even put everything under 777) and got the “no permssion” error.

    Any idea?

    I have the same issue on a Unix server using Firefox and where I have cleared the cache. I have deactivated all plug-ins and switched themes, with no progress. I also cannot place an image that is already in the media library nor access an image by URL. I *am* able to copy the image to the appropriate directory using Dreamweaver, but that’s as far as I can get. The image does not appear in my media browser once uploaded, but I don’t think that it ever has when manually uploaded.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    FYI – If a post is resolved, it’s in your best interest to make a NEW post.

    Ipstenu, the above thread I posted on last week was started 3 weeks ago and no one from support has offered any answers. I have the exact same issue as the original poster: a jQuery error. Can someone please look at that and help us out?

    same issue. this is so difficult to deal with… I wish I knew where to look. It’s not my plugins.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Can't Upload Images after updating to 3.3’ is closed to new replies.