WordPress.org

Support

Support » How-To and Troubleshooting » Can’t Upload Files/Images

Can’t Upload Files/Images

  • Unable to create directory *********/blog/wp-content/uploads. Is its parent directory writable by the server?

    Later i created the folders it asked now i get error :

    Warning: move_uploaded_file(******/blog/wp-content/uploads/2006/01/82_page_bkg.gif): failed to open stream: Permission denied in ************/blog/wp-admin/admin-functions.php on line 1757

Viewing 15 replies - 1 through 15 (of 35 total)
  • help someone

    can someone reply me????

    Update: Removed my previous posted info and questions.

    One of the moderators will or should be around to help ya soon though. They good at that lol!! =)

    spencerp

    Hi!

    When I want to upload an image or something first I get this answer:

    “Unable to create directory /***/wp-content/uploads/2006/01. Is /***/wp-content/uploads/2006 writable?”

    When I crate the directory …/uploads/2006/01 by myself, I’m able to upload images. But I think WP2 could do this automatically.

    Is there some help out there???

    Thanx!

    It seems, no one knows the solution!

    helllllllllo ?

    I’m having the same problem when I try to use the slick inline uploader.

    Also, my installation of WordPress 2 no longer has ANY options for file uploads — Miscellaneous Options now only has “Track links” and “Use legacy” checkboxes.

    Also, even if the uploader did work as it wants to, I want to choose my upload directory. Is this hardcoded now?

    These are pretty serious issues, but after an hour of searching, I can’t find documentation for the new “features.” Am I going to have to downgrade back to 1.5?

    chmod your folder to 0777

    it doesn’t work!

    Can someone help on this?

    problem with me was that i couldn’t chmod the newly created 2006 folder since it seemed like my ftp user wasn’t the owner.
    so i deleted it manually and chmod 777 it.

    then wp wanted to put a 01 directory in there.
    okay, same procedure again.
    i decided to create directories 01 up to 12, chmod777 to all of them, now it works.

    strange, though.

    hmm… lemme try!

    wordpress automatically makes the directroy, you msut make sure that your wp-content dir is CHMODed to 777

    wp-content dir is CHMODed to 777 ??????

    are you kidding?????????????????? Isn’t it risky to make that 777 ?

    dont make the wp-content folder 0777

    instead WP2.0 wants a uploads folder in the wp-content folder
    (wp-content/uploads/) make the uploads folder 0777 and you should be fine!

    This worked for me and this was what i meant with my earlier post. I assumed you knew i was talking about the uploads folder 🙂

    thanks friends, its working for me now! 😀

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘Can’t Upload Files/Images’ is closed to new replies.
Skip to toolbar