Can't upload files (jpg, zip, anything!) in the WP admin (9 posts)

  1. tedvieira
    Posted 3 years ago #


    Hosting: Hostway.com (no cpanel)
    WP Version: 3.4.2
    Theme: StudioPress child theme running on Genesis 1.8.2

    I can't....

    - upload/insert photos into posts using the upload/insert media uploader.
    - upload images to NextGen gallery
    - upload images (or any files) in the media library
    - upload and install themes or plugins (zip) from my hard drive.

    The error messages refer to there being no file, or file is empty (on any or every file I try)

    I can ftp files to the site, so the permissions on the wp-content folder seem to be okay.

    Any idea what could be causing this?

    Thanks so much!


  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  3. tedvieira
    Posted 3 years ago #

    Hey Esmi,

    thank you very much for your quick response.

    I've done everything you suggested and the issue still exists. I can't install any plugins or themes from my hard drive (zip format), and I can't upload any media files (jpg is all I've tried) from any of the upload options....

    - media library
    - upload/insert media uploader in posts/page toolbar
    - nextgen gallery uploader

    Any other thoughts?

    Thanks again!


  4. crickyt
    Posted 3 years ago #

    I am having the same problem with my site at http://www.epi.asia

    I just got the site running and so far have only been able to upload 2 images. I've deactivated all plugins. For me the main thing is to be able to upload media files thats all.

  5. cdukes
    Posted 3 years ago #

    I'd say double check site permissions. Just because you can FTP into a folder doesn't mean WP can write to it.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Can you post the exact error message?

  7. tedvieira
    Posted 3 years ago #

    @Cooper, Thanks cooper, I use Fetch for ftp and in earlier versions I used to be able to see the permissions of an item, but with this most current version I can't find that ability anymore.

    Also, the hosting company (hostway) doesn't use cPanel and I can't find any file manager in their hosting admin area to check from that side. I've sent a ticket to their support team.


    Yeah, thanks. I get a varied of different messages, depending on what I'm trying to use to upload a file. Basically the site won't let me upload files of any kind using any of the methods from the admin area.

    - Can't upload and insert photos via the posts/pages editor toolbar uploader
    - Can't upload files via the Media Library (uploader)
    - Can't use NextGen Galleries to upload photos
    - Can't upload plugins or themes (zip files)

    Here's the message I get when trying to use the uploader in the page/post editor.

    “” has failed to upload due to an error
    File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

    Thanks guys,


  8. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you checked your site's php.ini file and the post_max_size & upload_max_filesize?

  9. tedvieira
    Posted 3 years ago #

    Hey esmi,

    I didn't have access to the php.ini file but I did finally get a hold of hostway's customer support. The increased the limits in the file but the issue persisted and I haven't been able to get a hold of their support since.

    Solution: I moved the site to Hostgator. Everything works great. I wish I could've discovered the problem, but at least the client's site is running just fine now.

    Thank you, everyone, for your input on this!


Topic Closed

This topic has been closed to new replies.

About this Topic