Support » Localhost Installs » Can’t upload file to library XAMPP/Windows

  • blendergasket

    (@blendergasket)


    Hi! I haven’t worked with wordpress for a year or two and am now just coming back to it. I am helping someone with a site, and got it set up locally on XAMPP. For some reason though, I cannot add photos through the media library.

    I upload the picture and don’t get any error message, but the thumbnail is blank. I view source on the thumbnail and the URL points to the year/month folder structure. I checked this month folder, and it is empty. It seems like a permissions issue. I tried to make sure no files in the site were read only (the read only attribute had a square in it, which I unchecked and saved) and it still didn’t work.

    Strangely, the image does show when I click the edit image link. That image URL loads from the following location: src=”/[SITE]/wp-admin/admin-ajax.php?action=imgedit-preview&_ajax_nonce=70a5438d9f&postid=534&rand=49519″

    Has anyone had this issue and would you be willing to let me know if you have any advise for me in troubleshooting this matter? Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Manish Khutade

    (@dreampirates)

    you need enable in php.ini ;extension=fileinfo.so or ;extension=php_fileinfo.dll

    blendergasket

    (@blendergasket)

    Thank you for your response, I just checked my php.ini file and saw that it contains an uncommented “extension=php_fileinfo.dll”. It does not contain “”extension=fileinfo.so” at all.

    Hey Im Chris Brown luckily I found your query. We got same issue while working on wordpress. I dont need to post question here. I will just follow your post and check valuable responses.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.