WordPress.org

Support

Support » Themes and Templates » Can't upload featured image

Can't upload featured image

  • A while back I ran into this problem before, where the dashboard would error out when trying to upload a new image as a post’s featured image. I used the workaround found here (http://pastebin.com/gY3mTPJ7#) where you replace the functions file with the one I linked to. Well, something happened, the old functions file got uploaded again and now when I try to to the functions fix, it doesn’t work anymore; I just get this error:

    Parse error: syntax error, unexpected T_IF in /home/content/18/10066318/html/dsi/test/wp-content/themes/minimatica/functions.php on line 1

    I like this theme, but it looks like I may have to look for another one if I can’t avoid this media upload quirk 🙁

Viewing 3 replies - 1 through 3 (of 3 total)
  • Have you tried removing the theme, re-installing it, and then applying the fix? It seems to work for me.

    No, I haven’t, but I did read this in another thread:

    (from mjshade)

    Hi,
    I was reading other forum posts about this problem and found a suggestion that worked and was easy to implement.
    In your functions.php file, find this line of code:

    add_filter( 'ext2type', 'minimatica_mime_types' );

    and replace it with this:

    add_filter( 'ext2type', 'minimatica_file_types' );

    This completely fixed the featured images problem for me.

    That solution worked. Sorry, should have posted about it in here, forgot about it! 🙂

    I’m still having this problem after I tried re installing wordpress. I deactivated all plugins. Can someone please help. I can’t upload blog photos!! 🙁

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can't upload featured image’ is closed to new replies.